Helpful hints are enclosed in red brackets or round bubbles like this one!

THIS VERSION OF THE CREO PRIMER HAS BEEN EDITED FOR USE IN ME359: CAD & MACHINE ELEMENTS
Module 1

Introduction

This primer will introduce you to the modeling, visualization and design tools in Creo Parametric.

Creo Parametric is a leading 3D design program, used by many of the top product development companies in the world.

You will be taught how to use Creo Parametric to model two components for a construction kit - a cube and a strut.
You will then be shown how to create an engineering drawing of the square part.

An extended version of the primer containing an assembly and render exercise will be posted to Blackboard, but ME359 students will start the course with this revised version.
Module 2
Understanding the Creo Parametric interface

The Main Creo Parametric interface looks like this.

Main Interface Theory
The Creo Parametric user interface is easy to navigate with the key tools for a particular task contained in the ribbon across the top of the graphics area. Key elements of the main interface include:

Quick Access Toolbar — Contains commonly used tools and functions.

Ribbon Tabs — A set of tabs across the top of the interface. The active tab displays a set of tools in the ribbon immediately below. Here the View tab is active.
Graphics Area — The working area of Creo Parametric in which you view, create, and modify models such as parts, assemblies, and drawings.

Message Area — The message area provides you with prompts, feedback, and messages from Creo Parametric. Messages are logged and can be scrolled or the message window dragged to display more lines.

Dashboard — Locked at the top of the graphics area, the Dashboard appears when you create or edit a feature.

- The Dashboard provides you with controls, inputs, status, and guidance for carrying out a task, such as creating or editing a feature. Changes are immediately visible in the graphics area.
- Tabs along the bottom of the Dashboard provide additional feature options.
- Dashboard icons on the left include feature controls while the Pause, Preview, Complete Feature or Component and Cancel Feature options are grouped right of the center.
**Dialog Boxes** — Content-sensitive windows that appear, displaying and prompting you for information.

**Menu Manager** — A cascading menu that appears on the far right during the use of certain functions and modes within Creo Parametric. You select options working from top to bottom in this menu; however, clicking “Done” works from bottom to top. Bold menu options will be automatically selected if the middle mouse button is clicked.
Working directories and saving your work

The Working Directory is the location for opening files from and saving new files to.

Setting your Working Directory:

- Creo Parametric is started in a default working directory.
- The working directory is set before every session. When you exit Creo, it does not remember the working directory for the next session.

Open Files - The File Open dialog box looks first in the working directory.

Save Files - Files are saved to the folder they were opened from, this is not always the working directory.

Working Directory Theory

The working directory is the designated location for opening and saving files. The default working directory is the “Start in” location defined in the Creo Parametric start icon properties, typically “My Documents” or your “home” drive or folder on a network.

If you are not using PTC’s Windchill PDMLink to manage your Creo Parametric data, it is best practice to organize your work by creating a folder for each project. Each time you start Creo Parametric, you should set the working directory to the folder you plan to work in. In this course you will be instructed to create a folder and set that as your working directory.

There are four methods to set your working directory, use the method you are most comfortable with:

- From the Home tab - When Creo Parametric first opens, Click Select Working Directory from the Data group of the Home tab. Browse to locate the directory you wish to use, open it and click OK. This is the easiest and most straightforward method.

- From the File menu – If the Home tab is not available - Click File> Manage Session> Select Working Directory. Browse to the location that is to be the new working directory, select it and click OK.

- From the Creo Parametric Folder Tree or Browser - Right-click the folder that is to be the new working directory and select Set Working Directory from the pop-up menu.
From the Creo Parametric File Open dialog box - Right-click the folder that is to be the new working directory and select Set Working Directory from the pop-up menu.

You can browse directly to the working directory at any time by selecting Working Directory in the folder view of the Navigator panel on the left of the Creo window.

Opening Files

After you have set your working directory, you will see the files in that folder each time you click Open in Creo Parametric.

You can use any of the following methods to open a file:

- Click File> Open from the main menu, click Open  from the Quick Access toolbar or click Open  from the Home tab. Then, in the File Open dialog box, you either double-click the file you want to open or select the file and click Open.
- Browse to the desired folder using the Navigator to display its contents in the browser. Then, you either double-click the file you want to open or, right-click the file in the browser and select Open from the pop-up menu.
- Drag a file from the browser into the graphics area.

The File Open dialog box is the equivalent of the Navigator and Browser combination in the main interface.

Saving Files

By default, files are saved to the folder they were opened from. A new part, assembly, or drawing will be saved to the folder that is active when you click OK from the Save Object dialog box.

You can use any of the following methods to save a file:

- Click File> Save from the File menu.
- Click Save  from the Quick Access toolbar.
- Use the CTRL + S keyboard shortcut.

What have you learned?

- The layout of Creo Parametric’s user interface
- Interface items such as the Dashboard, dialog boxes, and the ribbon interface
- Working directories and file management
Procedure – Part Modeling – Corner cube

Scenario
This section will teach you how to model a cube shaped corner block for a construction kit.
You will create a new part, start an extrude, add a square sketch, and use this to extrude the cube shape.
Extruded circles will be used to create two of the holes and the Hole tool will be used for the third hole.
Rounds on the outer corners and chamfers on the holes will complete the model.
Task 1: Set working directory and create a new part

1. Start Creo Parametric.

2. In the Home tab, Data group, click Select Working Directory.

3. In the Select Working Directory dialog box
   - Navigate to the folder where you want to store your construction kit components. We suggest that you create a new folder (right-click and select New Folder from the pop-up menu) for each project you work on.
   - After you have browsed into the working directory folder, click OK to set that folder as your working directory.

4. Creating the new corner cube part model:
   - From the Quick Access toolbar or Home tab, click New.
   - In the New dialog box, notice the default object Type is Part and Sub-type is Solid; these are the correct options for creating a solid part.
   - Type CORNER_CUBE in the Name field and click OK.

   You cannot use spaces in filenames so use underscores or hyphens instead.

Create a folder in your X:\ drive something like:

X:\ME359\EX01_Primer\
4a. A “New File Options” dialog should open, and “bu_in_lbm_solid” should appear in the Template box.

If “bu_in_lbm_solid” isn’t already shown in the Template box, click “Browse” and navigate to V:\support\PTC\Creo3.0\Templates. You should see a bu_in_lbm_solid.prt – select it and click “Open”.

This is a template that has been created for you. It’s really just a standard Creo part file with standard “Model Properties” applied.

Once your window looks like the screenshot above, click OK.
5. Changing the display of datum features:
   - In the Graphics toolbar at the top of the graphics area, disable the display of all datum features except datum planes.

Think of datum planes as the framework your model will be built on.

Datum planes have a front or positive surface and back or negative surface.

The frame showing the placement of each datum plane is colored brown when viewed from the front (positive side) and gray when viewed from the rear (negative) side.

What have you learned?

- Setting working directories and starting new parts.
- Controlling the display of datum features
- Datum plane theory
Step 2: Start an Extrude

The easiest way to start creating solid geometry in Creo Parametric is to begin a 3D feature, in this case an extrude, then select the sketch plane. Extrude is just one of the “sketch based” features in Creo Parametric.

You will start an Extrude then select datum plane **FRONT** as your sketching plane.

1. Starting an Extrude (sketched) feature and defining the sketch plane:
   - Start the **Extrude** tool from the **Shapes** group of the **Model** tab.

   While using Creo Parametric, keep an eye on the prompt line at the bottom of the screen. There you will see messages telling you what Creo is doing, if there is a problem or what you need to do next. In this case you are being guided to select the sketch plane.

   - In the model tree or the graphics area, select datum plane **FRONT**.

   The Sketch tab will open and you will be able to start sketching. Two “Reference” lines will be visible on the Front datum plane.

   A sketch needs a minimum of two Reference lines to locate the geometry you create. In this case, Creo Parametric has created these automatically based on the other two datum planes.

What have you learned?

- Starting an Extrude (sketched) feature.
- Selecting a sketch plane.
- The Ribbon interface workflow.
Step 3: Create a sketch to define the shape of the cube

A 2D, 30 in square will be sketched on datum plane FRONT. The square will be drawn symmetrical about the intersection of the reference lines using a Center Rectangle tool. You will add an equal length constraint on two adjacent sides of the square.

1. Toggle off the display of datum planes:
   - In the Graphics toolbar, disable the display of all datum features.

2. Sketching the rectangle:
   - In the Sketch tab, select **Center Rectangle** from the Rectangle types drop-down menu.
   - In the Graphics toolbar, click **Sketch View** to reorient the sketch plane parallel to the screen.

   The model space will rotate until the sketch plane is parallel to the computer screen.
   - Move the cursor over the intersection of the two reference lines at **X1**, when the cursor snaps to the intersection, click to set the center of the rectangle.
   - Move the cursor diagonally and click **X2** to set a corner of the rectangle.
   - Middle-click in the graphics area to deselect the rectangle tool.

   (Middle-click means you should click down on the mouse wheel)
Sketches are controlled by two types of parametric constraints.

**Dimension constraints** allow you to alter sizes. Later you will use dimensions to define the size of this rectangle.

**Geometric constraints** including; equal length, parallelism, perpendicular, coincident, and so on. Creo has already applied many of these while you were sketching the square; to keep lines vertical/horizontal and make lines pass through the origin. Next, to change this rectangle to a square, you will apply an equal length constraint.

3. **Adding an “Equal Length” sketcher constraint:**

   You will add an Equal Length geometric constraint between two adjacent sides of the rectangle to make it a square. Creo Parametric is smart enough to remove one of the blue-gray (weak) dimensions to avoid over constraining the sketch.

   • Click X1 to select the top horizontal line in the rectangle. The line should change color to green to show it is selected.
   • Press and hold CTRL on the keyboard, then click X2 to add the vertical line to the selection. This line will also change color to green.
   • With both lines selected, right-click and select Equal from the pop-up menu (shown as X3).

   ![Image](image-url)

   Notice that one of the blue-gray “weak” dimensions has disappeared and a pair of L1 (Equal Length) constraints have appeared next to the selected lines.
There should now be just one dimension on the sketch. This is called a “weak” dimension and it is displayed in a blue-gray color. Sketch dimensions are “parametric” meaning when you change them the geometry will change to match the new value. You will change the dimension to 30 and lock it.

4. Changing a dimension to 30:
   - Move the cursor over the dimension value shown here at X1, and double-click.
   - Type the new value of 30 and then press ENTER.
   - Click in a blank area of the graphics window to de-select the dimension.

   The size of the square will change according to the new dimension value. You have just seen parametric control in action.

   • If necessary, click Refit from the Graphics toolbar. This will refit the sketch in the graphics area.

   The position and size of sketch lines are controlled by a combination of dimension constraints and geometric constraints.

   Notice that the dimension changed to a blue color, showing that it is now a strong dimension.

   Sketch geometry controlled by weak or strong dimensions can still be dragged. To fix dimensions so they cannot change accidentally, they must be locked.

5. Locking a dimension
   - Click to select the dimension. It turns green to show it is selected.
   - Right-click and hold on the selected dimensions and from the pop-up menu, select Lock.
   - Click in blank area of the graphics window to de-select the dimension.
The dimension will now be colored brown to show it is locked.

6. Reorient the model to its default orientation:
   • Press CTRL + D (on the keyboard, hold down the CTRL key and press D).

7. Click OK from the Close group of the Sketch tab to complete the sketch and return to the Extrude dashboard.

8. You will now see a preview of the extruded square, but longer than the image above.

What have you learned?

• Creating sketch geometry - center rectangles.
• Geometric constraints – overview, apply equal length.
• Dimension constraints, changing, weak, strong and locked.
• Viewing the model – default, flat sketch view and refit.
• Datum display - visibility.
• Dashboard interface.
Step 4: Complete the Extrude for the corner block

You will now edit the depth of the Extrude to be 30, extruding equally in both directions from the sketch plane so that the datum planes are at the center of the cube; this will be helpful when locating the holes later in this exercise. Extrude is a sketch based feature and this example used an “Internal” sketch.

1. If necessary, use the Graphics toolbar to disable the display of all datum features.

You can change how the extrude is defined either in the dashboard or on the model. Every element that defines the Extrude feature can be accessed from the dashboard.

After a feature is complete, you can use Edit Definition to re-open the dashboard and edit the feature.
2. Making changes to the extrude using the dashboard:

- In the extrude dashboard, click on the small triangle next to the depth option \( X_1 \) to open the drop-down menu. Select Symmetric from the list.
- Click in the depth field \( X_2 \), type 30 and press ENTER.
- Click Complete Feature from the dashboard.
- In the Graphics toolbar, click to refit the model in the graphics screen.

The new extrude feature is added to the Model Tree on the left of the screen.

3. Saving your work

- In the Quick Access toolbar, click Save.
- In the Save Object dialog, click OK to specify that the model will be saved to your working directory.

If the extrude dashboard mysteriously closes before intended, you probably middle mouse clicked. Engineers use many shortcuts to speed up their work and middle click is the shortcut to select Complete Feature and close the dashboard!

If you need to re-open the dashboard, right-click on Extrude 1 in the model tree and select Edit Definition from the pop-up menu.
What have you learned?

• Datum display - visibility.
• Viewing the model – Default orientation.
• Extrude – Remove material (cut), symmetric and through all.
• Dashboard to define and edit feature options.
• Edit features in the graphics area.
• Model Tree – stores features.
• Edit Definition to re-open and change existing features.
Dynamic Viewing

The orientation of your model within the graphics area is easily controlled using the mouse and the Graphics toolbar.

3D mode

- Spin
- Pan +
- Zoom
- Turn +

or

2D and 3D mode

Hold down the key and roll the mouse.

- Zoom

- Fine Zoom +
- Course Zoom +

2D mode

- Pan
- Zoom

In all of these, the middle mouse button (the wheel) needs to be held down.

It is possible to ‘lose’ the model from the graphics area by spinning or panning the model completely out of the display. If your model ever disappears from the window, click Refit from the Graphics toolbar or press CTRL + D.
Graphics Toolbar

The Graphics toolbar at the top of the graphics area controls how the model appears in the graphics area.

Experiment with the options to see the effect they have on the appearance of the model.
Step 5: Extrude the first hole

Instead of adding material, the extrude tool can also be used to remove material, in this case we use an extruded cut that is shaped like a circle. This extrude feature will be created by sketching an 8 in diameter circle on the front face of the cube. The extrude will remove material and intersect the entire cube.

1. If necessary, use the Graphics toolbar to disable the display of all datum features.

2. Starting an Extrude (sketch based) feature and defining the sketch plane:
   - Start the Extrude tool from the Shapes group of the Model tab.

3. Starting an internal sketch:
   - Press CTRL + D to reorient the model.
   - In the graphics area, click to select the front face of the cube X1, as the sketch plane. The Sketch tab will open and you will be able to start sketching immediately.
   - To make sketching easier while you are learning, click Sketch View from the Graphics toolbar; this will reorient the sketch plane parallel to the computer screen.
4. Sketching a circle:
   - Click **Center and Point** circle from the Sketching group of the Sketch tab.
   - Move the cursor until it snaps to the intersection of the reference lines \(X_1\), and click to locate the center of the circle.
   - Move the cursor away from the center and click at \(X_2\) to complete the circle.
   - Middle-click in the graphics area to deselect the circle tool.
   - Double-click the diameter dimension value \(X_1\), then type 8 and press **ENTER**.
   - Click in a blank area of the graphics window to deselect the dimension.

The circle will resize and the dimension will change color to show it is now **strong**.

5. Reorient the model to its default orientation:
   - Press **CTRL + D** to reorient the model.
   - Click **OK** from the **Close** group of the **Sketch** tab to complete the sketch and return to the Extrude dashboard.
By default, Creo Parametric will display a preview of the extruded circle, adding material, away from the model.

- Drag the drag handle (small white square) away from the model to add depth to the feature.
- Drag the drag handle the other direction, into the model to reverse its direction.

Notice that Creo Parametric is smart enough to know that extruding into the model requires material to be removed (a cut).

In the Extrude dashboard at the top of the graphics area, you will see that the Remove Material (X2) icon has been automatically enabled.

6. Experiment with extrude dashboard controls.
   - Click Change Depth Direction (X1) to toggle the extrude direction.
   - Click Remove Material (X2) to toggle between adding and removing material.
7. Defining the extruded (cut) circle.
   • Set the direction into the model.
   • Remove materials should be selected.
   • Select Through All \( \mathcal{X} \) \( (X3) \) from the depth drop-down menu, so that the extrude feature will intersect the entire model.
   • Press the middle mouse button and drag to spin the model and see that the extrude feature intersects the entire model.

   • In the dashboard, click Complete Feature to complete the extrude feature.
   • A second extrude feature is added to the model tree on the left of the screen.

8. Saving your work:
   • Press CTRL + D to reorient the model.
   • In the Quick Access toolbar, click Save.

   The first time you click Save, a dialogue box will open, allowing you to change the save location. For now, just click OK.

What have you learned?

   • Viewing the model – default, refit, 3D orientation, spin, pan, zoom, 2D pan and zoom.
   • Graphics toolbar – menu options.
   • Datum display – visibility.
   • Extrude – removing material (cut), changing direction and intersect with all surfaces.
   • Sketch – On surface, dashboard, center and point circle, dimension, lock dimension.
   • Dashboard to define and edit feature options.
   • Edit features in the graphics area.
   • Edit definition to re-open and edit existing features.
   • Saving the model.
Step 6: Extrude the second hole

You will use the technique used in Step 5, to extrude another 8 in diameter cut. This time, the circle will be sketched on the right side of the cube.

1. Starting an Extrude feature and defining the sketch plane:
   - Start the Extrude tool from the Shapes group of the Model tab.

2. If necessary, disable the display of all datum features.

3. Starting an internal sketch:
   - If necessary, press CTRL + D to reorient the model.
   - In the graphics area, click to select the right side of the cube X1, as the sketch plane.
The Sketch tab will open, presenting you with all of the sketching tools.
This time leave the model in default orientation while sketching the circle.
Look carefully and you will see two light blue “Reference lines”. One passes through the center of the sketch plane but the other along the back edge.

To easily locate the center of the circle at the center of the cube, you will create another reference using datum plane FRONT.

You could create this reference before sketching by clicking References \( 	ext{□} \) from the Setup group of the Sketch tab. It can also be created on-the-fly while sketching.

4. Enable the display of datum planes.

5. Creating a reference “on-the-fly”, while sketching a circle:
   - Click Center and Point circle \( \bigcirc \) from the Sketching group of the Sketch tab.
   - Press and hold the ALT key and move the cursor over datum plane FRONT \( (X1) \). When the datum plane pre-highlights in green, click to select it as a sketcher reference.
   - Release the ALT key and a new light blue reference line is created coincident with the FRONT datum plane.

Why a datum plane?

Datum planes, lines and points are well-defined construction elements that we can use to locate and constrain design features.
• Move the cursor until it snaps to the intersection of both reference lines in the center of the sketch plane and click (X1) to place the center of the circle.
• Move the cursor away from the center and click at X2 to complete the circle.
• Middle-click in the graphics area to deselect the circle tool.

6. Edit the diameter of the circle:
   • Double click the diameter dimension value X1, then type 8 and press ENTER.
   The circle will resize as soon as you press ENTER.

7. Click OK ✔ from the Close group of the Sketch tab to complete the sketch and return to the Extrude dashboard.

8. Disable the display of all datum features.
9. To flip the direction of the feature, click the small purple direction arrow (X1).

Notice that when the extrude direction was flipped into the model Remove Material was automatically enabled (X1).

10. Edit the depth of the extrude to intersect the entire model.
   - From the depth drop-down menu, select Through All (X2) so that the extrude feature will intersect the entire model.
   - Spin the model to see that the extrude feature intersects the entire model.
   - In the dashboard, click Complete Feature.
• The new Extrude feature is added to the bottom of the model tree.

11. Saving your work:
• In the Quick Access toolbar, click Save.

Accepting default names for features is fine for simple models like this. Complex models can have hundreds of features making it difficult to find a particular feature in the model tree to make edits.

It’s good practice to give key features recognizable names. Features can be renamed when they are being created or by clicking twice on the text in the model tree, making sure to pause between clicks.

What have you learned?
• Default orientation.
• Renaming feature names.
• References, specifying references on-the-fly while sketching geometry.
• Sketcher – Internal sketch, center and point circle and dimension.
• Extrude – Internal sketch, remove material, changing direction and intersect with all surfaces.
• Saving the model.
Step 7: Create the third hole

Now that you’ve created two holes, you should be able to create a third on the remaining axis.

Use the same method you used to create the second hole to create the third so that cube looks like the image below:

If you get stuck, return to Step 6 (page 27) and review the instructions you used for the second hole.
Step 8: Round edges of the cube

The Round feature is an “engineering” type feature applied to edges of a model. You will now add a 5 mm radius round to the twelve outside edges of the cube.

1. Press **CTRL + D** to reorient the model.

2. If necessary, disable the display of all datum features.

3. Edit the model display style to be Hidden Line:
   - In the Graphics toolbar, select **Hidden Line** from the Display Style drop-down menu.

   This display style will make it easier for you to see edges at the back of the model.
4. Start the **Round** tool from the **Engineering** group of the **Model** tab.
   - Notice the Round dashboard and the feature options.
     ![Round dashboard]

5. Defining the radius of the round:
   - In the dashboard, edit the radius **X1** to be 5 and press **ENTER**.

6. Selecting the edges to round:
   - Click to select one of the edges shown in **green**.
   - Press **CTRL** and select the remaining 11 edges shown in **green**.

   ![Selecting edges]

   If you select an edge by accident, keep the CTRL key held down and click the edge again to de-select.

   ![De-selecting edge]

   Note, this guide was written for Creo version 2.0. In Creo 3.0, holding down the CTRL button when creating some features (like rounds) is optional.

   - If you need to re-open the round dashboard, right-click the **Round 1** feature in the model tree and select **Edit Definition** from the pop-up menu.

7. Click **Complete Feature** to complete the round.

![Complete Feature]
8. Changing the display style and saving your work:
   • In the Graphics toolbar, select **Shading with Edges** from the Display Style types drop-down menu.

9. Saving your work
   • Click **Save** to save your work.

**What have you learned?**

- Engineering feature – Round.
- Round dashboard - radius.
- Selecting edge references – individual, adding more edges with CTRL key.
- Rotating the model.
- Edit Definition to re-open and edit existing features.
- Saving the model.
Step 9: Chamfer edges of the holes

The Chamfer feature is an “Engineering” type feature applied to edges of a model. You will now add 0.5 in chamfers to the six edges of the holes that intersect the outer surfaces of the cube.

1. Press **CTRL + D** to reorient the model.

2. If necessary, disable the display of all datum features.

3. Start the **Chamfer** tool from the **Engineering** group of the **Model** tab.
   - Notice the Chamfer dashboard and its feature specific options.

4. Defining the size of the chamfer:
   - In the dashboard, edit the chamfer width **X1** to be **0.5** and press **ENTER**.

5. Selecting the edges to chamfer:
   - Click to select one of the edges shown in **green**.
   - Press **CTRL** and select the other two edges shown in **green**.
6. Spinning the model to select more edges:
   • Release the **CTRL** key.
   • Spin the model to see the three edges that have not been selected.

   ![Model illustration](image)

   **Tip**

   If you middle-click but do not hold down the middle-mouse and move it to spin the model, the feature will complete with only the first three edges selected and the dashboard will close.

   To re-open the dashboard and select the remaining edges, right-click **Chamfer 1** from the model tree and select **Edit Definition** from the pop-up menu.

7. Selecting the remaining edges:
   • Press **CTRL** and select the remaining edges.

8. Completing the chamfer:
   • Click **Complete Feature** ![Complete Feature](image) to complete the chamfer.
   • Spin the model to see the completed chamfer feature.
   • **Save** your model
11. Saving your work and closing open windows from the Quick Access toolbar:
   - Click **Save** to save your work.
   - Click **Close Window** as many times as are required to close any open windows.

**What have you learned?**

- Engineering feature – Chamfer.
- Chamfer dashboard – width (D x D).
- Selecting edge references – individual, adding reference edges with CTRL key.
- Rotating the model.
- Edit Definition to re-open and edit existing features.
- Saving the model.
Module 2
Procedure – Part modeling - Strut

Scenario
Connecting the corner cubes will be struts with pegs at each end that fit into the holes in the corner cubes.

Note: for the first session of ME359, we’re not going to create the assembly (connect the structs and cubes).

The kit is based on 100 mm spacing between cube centers.
A strut length of 90mm provides clearance in the center of the cubes.

After creating a new part, you will sketch a small circle at the center of the strut and extrude this on both sides of the sketch to form the pegs. A larger circle, also located in the center of the strut, is extruded on both sides to form the shouldered section. Finally, a revolved arc cuts material from the strut to create the narrowed center section.

Thinking through your design ‘strategy’ before you start modeling is an important step. As you get better at CAD, you’ll spend more time doing this, as it will help you create models that are more robust (insensitive to design changes). This will enable you to create models that more closely reflect your design intent.

Design intent is how your model behaves when dimensions are modified. An example of design intent is how you create and dimension a hole in a block. The hole can be a certain distance from a corner or edge, or it can be in the middle of the face, for example, so that even if you make the block bigger, the hole remains in the center.
Step 1: Set working directory and create a new part.

If you just completed Module 1 and have not exited from Creo Parametric, you should skip tasks 1 and 2.

1. Start Creo Parametric.
2. Setting the working directory:
   - Click **Select Working Directory** from the **Data** group of the **Home** tab.
   - In the Select Working Directory dialog box, browse into the folder where you saved the Corner Cube model.
   - After you have browsed into the working directory folder, click **OK** to set that folder as your working directory.

The Strut part you create will be saved to and opened from this “working directory”, the same folder where your Corner Cube was saved.

3. Creating the new strut part model:
   - From the Quick Access toolbar or **Home** tab, click **New**.
   - Type **STRUT_100** in the **Name** field and click **OK**.

   You cannot use spaces in filenames so use underscores or hyphens instead.

   Click **OK** on the screen that prompts you to choose a template. (See details on page 10)

4. Changing the display of datum features:
   - In the Graphics toolbar, disable the display of all datum features except datum planes.
What have you learned?

- Setting the working directory.
- Create and name a new part
- Datum display – visibility
Step 2: Start an Extrude

You will start an Extrude choosing datum plane RIGHT as the sketch plane.

1. Starting an Extrude feature and defining the sketch plane:

   - Start the **Extrude** tool from the **Shapes** group.
   - In the model tree or graphics area, select datum plane **RIGHT**.

The Sketch tab will open and you will be able to start sketching. Notice the two “Reference” lines will be visible linked to datum planes FRONT and TOP

**What have you learned?**

- Starting an extrude feature.
- Selecting a sketch plane.
- Ribbon menu workflow.
Step 3: Create a sketch to define the peg diameter

An 8 in diameter circle will be sketched on datum plane RIGHT. The center of the circle will be located at the intersection of the horizontal and vertical sketch references. This sketch will be created in the 3D view, without reorienting to the 2D sketch view.

1. Sketching a circle:
   - In the Sketch tab, click **Center and Point** circle.
   - Move the cursor over the intersection of the two reference lines X1, when the cursor snaps to the intersection, click to place the center of the circle.
   - Move the cursor away from the center and click X2 to complete the circle.
   - Middle-click in the graphics area to deselect the circle tool.

2. Changing the circle diameter:
   - Double-click the diameter dimension value at X1, then type 8 and press ENTER.
Depending on how large your circle was first sketched, the resized circle may appear very small within the graphics area. This is common for the first sketch created in a new model and as you will see, it is nothing to worry about.

3. Refitting the sketch in the graphics area.
   - In the Graphics toolbar click **Refit** to refit the sketch within the graphics area.

4. Click **OK** from the **Close** group of the **Sketch** tab to complete the sketch and return to the Extrude dashboard.

**What have you learned?**

- Sketch – Center and Point circle.
- Dimensions – Changing value.
- Refit model to fit graphics window.
Step 4: Complete the Extrude that defines the length of the strut

You will now edit the depth of the Extrude to be 90, symmetrical on both sides of the sketch plane.

1. Making changes to the extrude using the dashboard:
   - Click **Blind** and then select **Extrude on both sides** from the depth drop-down menu (shown as X1).
   - Click in the depth field X2, type 90 and press **ENTER**.
   - Click **Complete Feature** from the dashboard to complete the extrude.

2. Saving your work:
   - In the Quick Access toolbar, click **Save**.
   - In the Save Object dialog, click **OK** to specify that the model will be saved to your working directory.

What have you learned?

- Extrude - sketch based feature, extrude on both sides.
- Dashboard interface.
- Saving the current model to the working directory.
Step 5: Extrude shoulder geometry

You will use the same technique used in Steps 2 - 4 to extrude a 12 in diameter circle sketched on the datum plane RIGHT. This feature will have a depth of 70 in, extruded on both sides of the sketch plane. This will form the shoulder of the strut.

1. If necessary, enable the display of datum planes.

2. Reorienting the model to its default orientation:
   - Press CTRL + D.

3. Starting an Extrude feature and defining the sketch plane:
   - Start the Extrude tool from the Shapes group.
   - In the Model Tree or graphics area, click to select datum plane RIGHT as the sketch plane.

4. With the Sketch tab now open, begin sketching a circle:
   - In the Sketch tab, click Center and Point circle.
   - Move the cursor over the intersection of the two reference lines X1, when the cursor snaps to the intersection, click to place the center of the circle.
   - Move the cursor away from the center and click X2 to complete the circle.
   - Middle-click in the graphics area to deselect the circle tool.
5. Changing the circle diameter:
   - Double-click the diameter dimension value at X1, then type 12 and press ENTER.

6. Completing the sketch:
   - Click OK from the Close group of the Sketch tab.

7. Disable the display of datum planes.

8. Defining the extrude to form the shoulder of the strut:

   By default, Creo Parametric displays a preview of the extruded circle adding material to the right of the sketch plane. You will now use options in the dashboard to make the feature extrude 70 in on both sides of the sketch plane.

   - Select Extrude on both sides from the depth drop-down menu (shown as X1).
   - Click in the depth field X2, type 70 and press ENTER.
• Click **Complete Feature**.

9. **Click Save** to save your work.

### What have you learned?

- Datum display – visibility.
- Viewing the model – default and spin.
- Extrude - sketch based feature, extrude on both sides.
- Sketch geometry – circle and change dimension.
- Dashboard interface.
- Saving the current model.
Step 6: Revolve a sketched arc to thin the center of the strut

You will use a Revolve feature with an arc sketch drawn on the FRONT datum plane to remove material around the center of the strut. This will make the strut lighter and reduce the amount of material being used.

1. If necessary, disable the display of all datum features.

2. Starting a Revolve (sketch based) feature and defining the sketch plane:
   - Start the Revolve tool from the Shapes group. Notice the Revolve dashboard and the revolve options.
   - In the model tree, click to select datum plane FRONT as the sketch plane.
   - In the Graphics toolbar, click Sketch View to reorient the sketch plane parallel to the screen.

   The model space will rotate until the sketch plane is parallel to the computer screen.
The sketch you will be creating must be snapped to the top silhouette edge of the strut. To do this, you will create geometry references on-the-fly, using the ALT key.

3. Starting an arc:
   - In the **Sketch** tab, from the arc types drop-down menu, select **Center and Ends**.
   - Move the cursor until it snaps to a point *X1* on the vertical reference above the strut. Click to place the center of the arc.

   - Move the cursor away from the center and you will see a construction circle previewing the size of the arc you are creating.
   - With the cursor over the top horizontal edge of the strut at *X2*, press the **ALT** key and click.
   - Release the **ALT** key and a light blue dashed reference line will appear along the top edge of the strut.
   - With the cursor over the reference line, also at *X2*, click to locate the start point of the arc.
   - Move the cursor to the right and click on the reference at *X3* to locate the endpoint of the arc.
   - Middle-click in the graphics area to deselect the arc tool.
5. Dragging the arc to resize it:
   - Click to select and drag the arc until it is above the horizontal reference line as shown by X1, then release the mouse button to place the resized arc.
6. Dimensioning the arc:
   - If necessary, zoom in closer to the arc.
   - From the Dimension group, click Normal Dimension.
   - Click to select the horizontal reference line at X1 in the illustration below.
   - Click the arc at X2.
   - Middle-click at X3 to place the dimension value.
   - Type 4 and press ENTER.

[Image of a dimensioned arc with X1, X2, and X3 labeled]

   - With the Normal Dimension still active, click the end of the arc shown at X1.
   - Click the other end of the arc X2.
   - Middle-click at X3 to place the dimension value.
   - Type 60 and press ENTER.
   - Middle-click to release the dimension tool.

[Image of the dimensioned sketch with dimensions 4 and 60 added]

The dimensioned sketch should look like this.
As well as a sketched profile, a revolve requires an axis of revolution. You will sketch a geometry Centerline to define the axis of revolution.

7. Adding a geometry center line:

- In the Datum group of the Sketch tab, click the Centerline tool.

Make sure you select the centerline tool from the Datum group, not the Sketching group.

- Click on the horizontal reference at X1 to start the centerline and at X2 to end it. Be sure both are snapped to the horizontal reference.

- Press CTRL + D to reorient the model to its default orientation.

- Click OK to complete the sketch and return to the Revolve dashboard.

The preview of the feature shows the dimension defining the revolve feature as 360 degrees around the axis of rotation.

8. Editing the Revolve feature to remove material from the strut:

- Make sure the Revolve as solid (X1) option is selected in the dashboard.
- Click to enable the Remove Material X2 option from the dashboard.

Material will be removed from the side of the sketch shown by the purple material.
direction arrow.

• Click **Complete Feature**.

9. Click **Save** to save your work.

**What have you learned?**

- Datum display – visibility.
- Viewing the model – default, perpendicular to the sketch plane.
- Sketch – Adding new references on the fly.
- Sketch geometry – arc, geometry centerlines, drag geometry.
- Sketch dimensions – editing, adding new.
- Revolve - sketch based feature, profile and a centerline.
- Revolve dashboard – revolving as a solid, remove material.
- Saving the current model.
Step 7: Round edges of the strut

Rounds are “Engineering” features and are applied to edges of the model. You will add 0.5 in radius rounds to the shoulders of the strut. This will make it smoother for handling and help with injection molding.

1. Hiding the display of datum features.
   • If necessary, disable the display of all datum features and press CTRL + D to return the model to its default orientation.

2. Starting the Round feature.
   • From the Engineering group, start the Round tool.

3. Defining the radius of the round:
   • In the dashboard, edit radius X1 to be 0.5 and press ENTER.

4. Selecting the edges to round:
   • Select one of the edges shown in green.
   • Hold down the CTRL key and select the other edge shown in green.
   • Click Complete feature to complete the round.

5. Saving your work:
   • If necessary, press CTRL + D to reorient the model to its default orientation.
   • Click Save to save your work.
What have you learned?

- Engineering feature – Round.
- Round dashboard – setting the radius.
- Selecting edge references – individual, adding reference edges using CTRL key.
- Saving the model.
Step 8: Chamfer the ends of the strut

Like rounds, chamfers are also “Engineering” features and are applied to edges of the model. You will add 0.5 in. chamfer to the both ends of the strut. This will make it easier to insert the strut ends into the holes of the cubes.

1. Start the Chamfer tool from the Engineering group of the Model tab.
   - Notice the Chamfer dashboard and its specific options.
2. Defining the size of the chamfer:
   - In the dashboard, edit the size of the chamfer width to be 0.5 and press ENTER.

3. Selecting edges to chamfer:
   - Select one of the edges shown in green.
   - Press CTRL and select the other edge shown in green.
   - Click Complete feature.

4. Saving your work:
   - If necessary, press CTRL + D to reorient the model to its default orientation.
   - Click Save to save your work.

You can close this part now, we’re done with it for today.
What have you learned?

- Engineering feature – Chamfer.
- Chamfer dashboard – setting the width (D x D).
- Selecting edge references – individual, adding reference edges using CTRL key.
- Saving the model.
Module 5
Procedure - Engineering drawing

Scenario
The final section of this introductory tutorial teaches you how to create an engineering drawing from a Creo Parametric model.

This process is largely automated and, because models and drawings are “associative”, changes to the model are immediately reflected in the drawing.

Configuring Creo

Creo is configured through the use of a set of templates; these include program settings, the format, title block, default text, units, drawing size, etc.

The templates are located at V:\support\PTC\Creo3.0\Templates. When you open Creo at BU (on a BU computer or Citrix), Creo automatically points to this location and uses these templates.

BU students can save a copy of their own templates on their X:\ drive, but you will have to re-direct Creo to look at or use these anytime you start Creo.

NOTE: The copy of the corner cube drawing that you submit for homework should look like the pdf included in the homework zip file, not like the drawing shown here.
Step 1: Set working directory and open cube corner

If you just completed Module 4 and have not exited from Creo Parametric, tasks 1-2 below do not need to be performed, please skip to Step 3.

1. Start Creo Parametric:

2. Setting the working directory:
   - Click **Select Working Directory** from the **Data** group of the **Home** tab.
   - In the Select Working Directory dialog box, browse into the folder where you saved the other Primer models.
   - After you have browsed into the working directory folder, click **OK** to set that folder as your working directory.

3. Open the Corner Cube:
   - Click **Open** from the Quick Access toolbar or Home tab.
   - From the File Open dialog box, double-click **corner_cube.prt** to open it.

   **Important:** NEVER try to open Creo part or drawing files by clicking on them in the Windows Explorer.

   This will usually cause them to open in Creo Simulate (or another Creo product).

   The best practice is to set the working directory to the file location, and then open the files from within Creo Parametric.
Step 2: New engineering drawing

Drawing templates in Creo Parametric will use the part open on screen as the basis for an engineering drawing. The A3/B size templates automatically create a border, title block, three orthographic views and a pictorial representation! Dimensions are easily imported from the 3D model and annotations added.

1. Starting a new drawing:
   - In the Quick Access toolbar, click New to start a new file.
   - In the New dialog box, click to select Drawing as the model type.
   - Type Corner_cube in the Name field then click OK.

For ME359 and other BU students:

a. Choose “Use Empty with Format”.

*The format includes the drawing border and title block, which has been created for you. Several variations are stored at V:\support\PTC\Creo3.0\Templates

b. Under the lower “Template” section, the text box should read: “BU_C_SIZE”.

c. If it doesn't: click “Browse…”

c. Navigate to: “V:\support\PTC\Creo3.0\Templates\bu_c_size.frm”.

d. Highlight it and click open to use it for your drawing.
2. Click OK; the drawing will now open.

3. Select the Layout Group on the Dashboard at the top of the window

4. Click “General View”
   a. The “Select Combined State” window will appear
      i. Select No Combined State
      ii. Click OK

5. Left Click in the BOTTOM-LEFT quadrant of the drawing and a drawing view will be inserted

6. The Drawing View popup will open where the view conditions of the view are specified.
   a. For now, choose “FRONT”, and click OK
   b. Left-Click once in the drawing space to refresh it.

7. Left-click once on the FRONT view to select it. The border will be a dark green dashed line.


9. Move the mouse to the right of the FRONT view and click in the space to insert a RIGHT view.

10. Left-click once again on the FRONT view to select it.

11. Click again on “Projection View” in the Layout Group on the Dashboard.

12. Move the mouse above the FRONT view and left-click in the empty space to place a TOP view.

13. Middle-click to deselect.

14. Click “General View” and OK (No combined state) again.

15. Left-click into the top right quadrant of the drawing space
   a. Choose “Default Orientation” from the Model View list, and click Apply
   b. Click View Display from the left menu of the Drawing View window
   c. Change the Display Style to “Shading” and click OK

16. CTRL-click the three projected views

17. Right-click (wait for the menu) and choose Properties

18. From the “Tangent Edges Display Style” menu, choose “Solid”. This adds tangent lines to the views.

19. Click OK

20. You now have a drawing with three projected orthographic views, and one isometric view.
Step 3: Changing the drawing scale

Automatic creation of the drawing will have chosen a scale to match the size of the model to the paper size. The scale is displayed below the drawing.

1. Changing the drawing scale:
   • At the bottom left corner of the drawing screen, double click on **SCALE: 1:1**.
   • In the Scale dialog at the top of the graphics area, enter a value for scale and click **Accept Value** to apply the new scale to the drawing.

   ![Scale Dialog](image)

   **NOTE:** The copy of the corner cube drawing that you submit for homework should look like the pdf included in the homework zip file, not like the drawing shown here.
You should always choose a scale that would be listed in a national or international standard. If Creo Parametric does not change the scale, try a different value.

What have you learned?

- Drawing scale – changing the scale.
Step 4: Moving views

By default, views are locked in position and will need to be unlocked before they can be moved.

1. Unlocking a view:
   - In the drawing, click on the lower left view to select it. The view border will turn green to show it is selected.
   - Right click and pause, from the pop-up menu, select Lock view movement to allow the view to move.

2. Moving a view:
   - Click and drag the view to a new location.

   If you are dragging the front view, you should see the other “projected” views move to keep them orthogonal as you drag.

   - When you have finished moving the views you can lock them again by repeating step 1.

What have you learned?

   - Drawing views – unlocking, moving, locking.
Step 5: Editing the Title Block, Notes Field and Printing Drawings

For your first homework assignment and many others, you will need to print the drawing you create in Creo. Follow these instructions below to edit the Title Block on the drawing, and print your drawings to PDF and paper.

Editing the Title Block and Notes Field

1. To edit the title block on a drawing, the Annotate tab on the Ribbon must be highlighted. For ME359, the Title Block includes the: Part Number, Part Description, Drawing Revision Number, Default Tolerances, Student Name & E-mail Address, Drawing Size, Sheet Number and Sheet Scale
   a. Look at your drawing and make sure you can find and identify all of these fields.
   b. Double-click on the fields you need to change to edit their values.

2. For ME359 Homework Part Number, students should use the following scheme:
   a. ME359HW01P01
      i. Indicates ME359 Homework #1, Part #1
   b. ME359HW04P12
      i. Indicates ME359 Homework #4, Part #12
   c. Change the Part Number now, if you haven’t already

3. For work in other classes
   a. Come up with something that makes sense for you and your group
   b. Decide before you get started to make things easier on yourself
      i. Use a spreadsheet to keep track
         1. Your ME460 or ME461 project may contain a few hundred parts...

4. A Part Description is used with a Part Number to easily describe parts
   a. Descriptions should be concise, but not too generic
      i. Calling items just “Bracket” or “Plate” quickly gets confusing
   b. When Creating Part Descriptions
      i. Consider the name of the assembly the part is going into
      ii. Consider the function of the part
      iii. Abbreviations are okay, for example:
          1. If the part is a plate onto which a motor mounts:
             a. Motor Mount Plate
          2. If the part is a manifold for a fluid regulation subassembly:
             a. Regulator Manifold
          3. The part is a cover the main fluid reservoir in the manifold:
             a. Regulator Body Reservoir Cover
             b. Abbreviated on the drawing as: Reg Body Rsvr Cover
   c. Change your Part Description now, if you haven’t already.
5. Drawing Notes include Part Material, Notes for common rounds and chamfers, Material processing notes, Callouts for particular specifications, Handling, Packaging, or Finishing instructions, Notes on vendor, purchasing, and Anything that doesn’t fit anywhere else.
   a. ME359 Notes should always include at least:
      i. A note indicating which standard to use (ASME)
      ii. The material (see the first homework assignment for an example)
   b. To edit a note:
      i. Double-click on the notes field on any drawing to edit that field.
   c. To add a new note:
      i. On the Annotate Tab, click the Note button, click the drawing to place the note and add text.

Printing Drawings

1. As with most programs, it’s possible to use File > Print in Creo, but this can cause issues with paper sizes. For that reason, in ME359 it’s STRONGLY recommended that you:
   a. SAVE the drawing to a PDF first, then print the PDF.
      i. This has the added benefit of creating a record of your work, should anything go wrong with your Creo drawing or part file, making your original drawing inaccessible.

2. To save your drawing as a PDF:
   a. Open any drawing, and choose File > Save As
      i. Note: Clicking Save As is the same as using the arrow to choose Save a Copy
      1. DO NOT choose Save a Backup or Quick PDF Export

3. The Save a Copy window will open
   a. Drop the Type menu down and choose PDF (*.pdf)
   b. Check or edit the file name (case sensitive) and choose OK

4. The PDF Export Settings window will open; change the settings to match the ones below (Figure 1)
   a. Change the color to Grayscale
   b. You may also like to change the resolution to 600 dpi

5. Click OK to save the PDF.

6. Next, open the PDF with Acrobat and print it from Windows as you would any document. For the purpose of this exercise, you can print the drawing you made in the Primer.

7. When you are finished with this exercise, raise your hand and show the instructor or one of the TA's your work so that they can give you credit for completing it. This and the other class exercises comprise 5% of your ME359 course grade.

Figure 1. PDF Export Settings

© 2018 Peter A. Zink. All rights reserved.