About the PTC Academic Program

3D CAD, Collaboration and Calculation Management Software for High Schools, Colleges & Universities

The PTC Education Program began in 1999, as a way to help teachers and professors bridge the gap between education and industry. We know that technology and innovation are keys to success in the global marketplace; and that companies look for students with the most up-to-date skills. For that reason, PTC is actively working with industry, secondary school teachers and university professors to develop a complete education solution - from the secondary school all the way to the college/university level. PTC is committed to building a new generation of "technological thinkers" and helping students gain access to technology education programs and innovative skills for the future.

Today, more than 35,000 schools and ten million students are using PTC solutions. In addition, our software has been incorporated in over 1800 universities globally, including 50 of the top mechanical engineering universities in the United States. The number of schools and universities continues to grow every year. We're proud to be part of a technological literacy movement that seeks to help bridge the academic gap and inspire all students to design the products of the future, because the designers of the future are our future too.

With PTC’s School & University Program, students can:

• Build technological literacy
• Learn to work collaboratively in teams
• Develop communication, interpersonal and social skills
• Improve critical thinking and strategic thinking skills
• Increase confidence
• Experience project-based problem solving
• Become familiar with advanced design processes
• Prepare for real-world careers in technology
Contact Information – PTC Academic Program

General PTC Academic Program Questions
• Email: PTCEducation@ptc.com

Creo for Schools
• Email: schools@ptc.com
• Web: www.ptcschools.com

DOD STARBASE
• Email: starbase@ptc.com
• STARBASE Support Pages
  – www.starbasedod.org
  – www.ptc.com/go/starbase

FIRST Robotics
• Email: firstsupport@ptc.com
• FIRST Support Pages
  – www.ptc.com/go/first

RWDC - Real World Design Challenge
• Email: rwdc_support@ptc.com
• RWDC Support Pages
  – www.realworlddesignchallenge.org
  – Aviation Challenge: www.ptc.com/go/rwdcgettingstarted
  – Surface Challenge: www.ptc.com/go/surfacegettingstarted

Scalextric4Schools
• www.scalextric4schools.org
## Training Agenda

### Day 1
- **Module 01** — The Interface and Basic Concepts
- **Module 02** — Basic Part Modeling

### Day 2
- **Module 03** — Basic Drawing Creation
- **Module 04** — Basic Assembly Modeling
- **Module 05** — Advanced Modeling and Design
- **Module 06** — Photorealistic Rendering
## Table of Contents

### Creo Parametric 2.0 - Advanced Primer

**The Interface and Basic Concepts** ........................................ 1-1
- Configuring Creo for the Advanced Primer .......................... 1-2
- Downloading Model Files for the Advanced Primer ................. 1-9
- Understanding Solid Modeling Concepts ............................ 1-10
- Understanding Feature-Based Concepts ............................ 1-11
- Understanding Parametric Concepts .............................. 1-12
- Understanding Assembly Concepts ................................ 1-14
- Understanding Associative Concepts .............................. 1-15
- Understanding Model-Centric Concepts .......................... 1-17
- Understanding the Creo Parametric Interface ..................... 1-18
- Working Directories and Saving your Work ....................... 1-22
- Managing Files in Creo Parametric ............................... 1-24
- Understanding Datum Display Options ............................ 1-32
- Understanding Display Style Options ............................. 1-37
- Using Spin, Pan, Zoom and Named Views ......................... 1-41
- Selecting Items using Direct Selection .......................... 1-47
- Understanding Selection Filters .................................. 1-49
- Using the Smart Selection Filter ................................. 1-50
- Selecting Items using Query Selection .......................... 1-55
- Understanding the Basics of Sketcher ............................ 1-61

**Basic Part Modeling** ...................................................... 2-1
- Basic Part Modeling .................................................. 2-2

**Basic Drawing Creation** ................................................. 3-1
- Basic Drawing Creation ............................................... 3-2

**Basic Assembly Modeling** .............................................. 4-1
- Basic Assembly Modeling ............................................. 4-2

**Advanced Modeling and Design** ..................................... 5-1
- Advanced Modeling and Design ..................................... 5-2

**Photorealistic Rendering** ............................................... 6-1
- Photorealistic Rendering ............................................. 6-2
Module 1

The Interface and Basic Concepts

Module Overview
In this module, you will learn about basic concepts and benefits of solid modeling using Creo Parametric.

This module also introduces you to the main user interface, defines each area and how you will use it. You will gain an understanding of basic skills including setting the working directory and saving and opening files. You will learn basic Creo Parametric display, orientation, and selection options.

Finally in this module, you will also learn the basics of using the sketcher and how to create a simple part model.

Objectives
After completing this module, you will be able to:
• Configure Creo Parametric for this course.
• Download the model files used in this course.
• Understand solid modeling concepts.
• Understand feature-based concepts.
• Understand parametric concepts.
• Understand assembly concepts
• Understand associative concepts.
• Understand model-centric concepts.
• Understand Creo Parametric's main interface.
• Use working directories and saving your work.
• Use spin, pan, zoom, and predefined named views to orient models.
• Understand basic display options including model and datum display.
• Select models, features, and model geometry using your mouse.
• Understand the basics of sketcher and sketcher orientation.
Configuring Creo for the Advanced Primer

Before starting any of the Advanced Primer exercises, make sure your installation of Creo Parametric is configured properly.

The Advanced Primer Configuration:

Unit System
• Length - Millimeter
• Mass - Kilogram
• Time - Second

Drawing Standard – ASME

Template Models – Academic Program

Folders in “creo_standards”

Configuration Batch File

PTC Academic Program – Creo Standards

To help configure your installation of Creo Parametric, the PTC Academic Program provides a special folder named *creo_standards*. If you install the M010 build code of Creo in the default location, the creo_standards folder will be located in: C:\Program Files\PTC\Creo 2.0\Common Files\M010.

The folder M010 is the build code folder. Because its name will change with each software release, you may see a folder with a different name.

Production releases are named using the M prefix and a three digit number such as 010. Pre-production build codes use an F prefix followed by a three digit number starting with 000.

Inside the *creo_standards* folder, are a set of files and folders that are used to configure Creo Parametric. The batch file named *configure* is used to quickly and automatically configure Creo Parametric to use selected unit systems and drawing standards.
The Creo Parametric Advanced Primer Configuration

To configure Creo for the **Creo Parametric Advanced Primer**, run the batch file named `configure` and choose option “2 – ASME drawings with MMKS unit system”.

This will configure your installation using the following options:

- **Unit System**
  - Length - Millimeter
  - Mass - Kilogram
  - Time - Second
- **Drawing Standard** – ASME
- **Template Models** – Academic Program (mmks)
**PROCEDURE - Configuring Creo for the Advanced Primer**

**Scenario**

The Creo Parametric Advanced Primer was developed using the MMKS unit system and ASME drawing standard. In this topic you will check to see if your installation of Creo Parametric is configured using the same configuration. If it is not, you will learn how to configure your installation for the course.

**Step 1:** Check to see if your installation is configured properly.

<table>
<thead>
<tr>
<th>In this step you will check to see if your installation of Creo is configured for this course.</th>
</tr>
</thead>
</table>

1. If necessary, start Creo Parametric 2.0.
2. In the Quick Access toolbar or the Home tab, click **New**.
3. In the New dialog box, disable **Use default template** and click **OK**.

4. If in the New File Options dialog box you see **solid_start_part_mmks** listed as the default template, your installation is configured correctly:
   - You can now continue to **Step 5** and then to the next topic (Downloading Model Files for the Advanced Primer).

5. If **solid_start_part_mmks** is not the default template, continue to **Step 2**.
Step 2: Run the configuration batch file to configure your installation.

Inside the creo_standards folder you will find a batch file named configure. You can run this batch file to configure Creo Parametric to use different unit systems and drawing standards.

1. If necessary, exit Creo Parametric 2.0.
2. In Windows Explorer, browse to the folder C:\Program Files\PTC\Creo 2.0\Common Files\M010\creo_standards:
   • Double-click the batch file named configure and then type 2 to apply the “2 – ASME drawings with MMKS unit system” configuration.

![Batch file selection window]

The folder M010 is the build code folder. Because its name will change with each software release, you may see a folder with a different name. You should use the latest build code available. Production releases are named using the M prefix and a three digit number such as 010. Pre-production build codes use an F prefix followed by a three digit number starting with 000.

3. If you receive “Access denied” messages when running the batch file, move to Step 3 and change access permission on the Common Files folder.
4. If you do not receive “Access denied” message, return to Step 1 and double check that Creo is configured properly.

Creo should now be using the following units and drawing standards:
• Length - Millimeter
• Mass - Kilogram
• Time - Second
• Drawing Standard – ASME
Step 3: Give yourself full control of the Common Files folder.

Check to see if you have full control of the Common Files folder. This is required to configure your installation using the batch files. The procedure for checking permissions will vary depending on the operating system you are using. The following instructions are based on the Windows 7 operating system.

1. If necessary, exit Creo Parametric 2.0.
2. In Windows Explorer, browse to the folder C:\Program Files\PTC\Creo 2.0:
   • Right-click the Common Files folder and select Properties from the pop-up menu.
3. In the Common Files Properties dialog box:
   • Select the Security tab and select your user name.
   • If Allow is checked for Full control, then you have full control of this folder and you can return to Step 2 and configure your installation.
   • If Allow is not checked for Full control, continue to Step 4 where you will change permissions so that you have full control of the Common Files folder and all of its subfolders.
Step 4: Give yourself full control of the Common Files folder.

To change access permission on the Common Files folder, you will need administrator access to your computer. The procedure for changing permissions on a folder will vary depending on the operating system you are using. The following instructions are based on the Windows 7 operating system.

1. In the Common Files Properties dialog box, click Edit.
2. In the Permissions for Common Files dialog box:
   - Click Add.
   - In the new dialog box, type the word Everyone and then click OK.
   - Select Everyone from the Group or user names list.
   - Enable the Full control check box to Allow full control.
   - Click OK.
3. From the Common Files Properties dialog box, click OK.
4. From the Confirm Attribute Changes dialog box:
   - If necessary, enable Apply changes to this folder, subfolders and files.
   - Click OK.

If necessary, you can now return to Step 2 and configure your installation for the Creo Parametric Advanced Primer.
Step 5: Applying other unit system and drawing standard combinations.

If necessary, after completing the Creo Parametric Advanced Primer, you can use the `configure` batch file to reconfigure your installation.

1. Below is a list of the available unit system and drawing standard combinations:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ASME drawings with INLBS unit system</td>
</tr>
<tr>
<td>2</td>
<td>ASME drawings with MMKS unit system</td>
</tr>
<tr>
<td>3</td>
<td>AS1100 drawings with (3rd Angle) MMKS unit system</td>
</tr>
<tr>
<td>4</td>
<td>BS8888 drawings with MMKS unit system</td>
</tr>
<tr>
<td>5</td>
<td>ISO drawings with (1st Angle) MMKS unit system</td>
</tr>
<tr>
<td>6</td>
<td>ISO drawings with (3rd Angle) MMKS unit system</td>
</tr>
<tr>
<td>7</td>
<td>Default Creo “metric” configuration</td>
</tr>
<tr>
<td>8</td>
<td>Default Creo “english” configuration</td>
</tr>
</tbody>
</table>

The option “7 – Default Creo “metric” configuration” should be used to configure Creo for courses found in Schools PLMS.

This completes the procedure.
Download and Extract the Course Model Files

Before beginning this course, download and run the self-extracting zip file named Creo2_Adv_Primer.exe. This file contains the model files required for completing the Advanced Primer.

Download and Extract the Course Model Files

Use the instructions below to download and extract the model files required for the Creo Parametric 2.0 Advanced Primer:

1. Use http://apps.ptc.com/schools/Creo2_Adv_Primer.exe to download the self-extracting zip file.
2. Double-click Creo2_Adv_Primer.exe to run the self-extracting utility.
   • Your security settings may require you to verify that you want the program to run.
3. From the Creo Parametric 2.0 Advanced Primer dialog box:
   • Read the extraction instructions and then click Yes to continue.
4. From the WinZip Self-Extractor – Creo2_AdvPrimer.exe dialog box:
   • Click Browse and navigate to the location you want the Creo2_Adv_Primer folder copied to.
     – We suggest that you choose your Documents or Desktop folder.
     – After you have navigated to the folder, click OK.
   • Click Unzip.
     – When finished, the WinZip Self-Extractor dialog box will display “155 file(s) unzipped successfully”.
     – Click OK.
   • Click Close to complete the extraction process. You are now ready to start the course.
Understanding Solid Modeling Concepts

Creo Parametric enables you to create solid representations of your part and assembly designs.

**Solid Models:**

- Are realistic visual representation of designs.
- Contain properties such as mass, volume, and center of gravity.
- Can be used to check for interferences in an assembly.

### Interference Check

### Mass Properties

**Understanding Solid Modeling Concepts**

Creo Parametric enables you to create realistic solid representations of your part and assembly designs. These virtual design models can be used to easily visualize and evaluate your design before costly prototypes are manufactured.

The models contain material properties such as mass, volume, center of gravity, and surface area. As features are added or removed from the model, these properties update. For example, if you add a hole to a model, then the mass of the model decreases.

In addition, solid models enable tolerance analysis and clearance/interference checking when placed into assemblies.
Understanding Feature-Based Concepts

Creo Parametric is a feature-based product development tool.

With Feature-Based Modeling:

• You build one simple feature at a time.
• Each new feature can reference previous features.

![Wheel Features]

Understanding Feature-Based Concepts

Creo Parametric is a feature-based product development tool. The models are constructed using a series of easy to understand features rather than confusing mathematical shapes and entities.

The geometric definition of a model is defined by the type of features used and by the order in which each feature is placed. Each feature builds upon the previous feature and can reference any of the preceding features; this enables design intent to be built into the model.

Individually, each feature is typically simple but as they are added together they form complex parts and assemblies.

In this example, we have a slot-car wheel showing the first six stages of its creation:

• First, a circle is extruded to create a cylindrical solid.
• An additional circle is extruded to add material to the middle of the wheel.
• A third circle is extruded to remove material from the wheel.
• A fourth circle is extruded to add a hub inside the wheel.
• A coaxial hole is created on the previous extrusion.
• A chamfer is created on the edge of the hole.
Understanding Parametric Concepts

The parametric nature and feature-to-feature relationships in Creo Parametric enable you to easily capture design intent and make design changes.

Parametric:

- Model geometry is defined by features.
- Features are defined by parameters, references and dimensions.
- When you modify dimension values, relevant geometry is automatically updated.

Parent/Child Relationships:

- Features referenced during creation become parents.
- If parent features change, child features accordingly and predictively change as well.

Understanding Parametric Concepts

Creo Parametric models are value driven, using dimensions and parameters to define the size and location of features within the model. If you change the value of a feature dimension, that feature will update according to the change. The change then automatically propagates through to related features in the model, updating the entire part.

Parent/Child Relationships

Relationships between features in Creo Parametric provide a powerful tool for capturing design intent. During the modeling process, design intent is added as one feature is created with reference to another.

When creating a new feature, any feature referenced during its creation becomes a parent of the new feature. The new feature referencing the parent is referred to as a child of the parent. If the parent feature is updated, any children of the parent update accordingly. These relationships are referred to as parent/child relationships.

This example shows a piston model intersected with a hole feature. In the middle figure, the piston height is modified from 18.5 to 25. Notice that the hole moves upward as the piston height increases. The design intent of the piston is to have the hole located a specified distance from the top of the
piston. The hole will maintain that distance no matter how tall the piston becomes. This intent was added by dimensioning the hole to the top surface of the piston.

Alternatively, if the intent of the design is to have the hole located a specified distance from the bottom of the piston, the hole would be dimensioned from the bottom surface of the piston, yielding a different result when the height of the piston is modified.

The right most figure shows modifications made to the location and diameter of the hole.

**Best Practices**

When creating features in your model, try to reference features and geometry that are robust, will likely not be deleted, and provide the desired design intent. While this is not always possible, striving to do so will help you build robust, easy to modify models.
Understanding Assembly Concepts

An assembly is a collection of parts and other sub-assemblies that you bring together using constraints.

- Capture assembly design intent using constraints.
- Create assembly constraints.

An Assembly Model that is Comprised of Parts

Understanding Assembly Theory

There are multiple methods to assemble components using Creo Parametric. Assembling components with constraints is one of the primary methods used to create Creo Parametric assemblies.

After you create and name the new assembly, you can begin adding parts to the assembly. Similar to part models having design intent, assemblies also contain design intent. Assembly design intent is based upon which component is assembled first, and the constraints that you use during the assembly process. Design intent is important because it means that your assembly updates in a predictable manner when edited.

All characteristics that hold true for assemblies also hold true for sub-assemblies. In fact, a sub-assembly is nothing more than an assembly that is assembled into another assembly.

Creo Parametric has several types of constraints, such as Coincident, Distance, Angle Offset and Parallel. Use of these constraints is made easier by using the Automatic option, which enables Creo Parametric to automatically select a constraint type based upon the orientation and position of the component and the references you select.

Every assembled component has a Placement node in the model tree that can be expanded to view the constraints used in that component's placement.

Assembling with component interfaces is a second method when assembling components. This method is especially useful when assembling common components because it can significantly cut the number of selections that you make when constraining a component. By using component interfaces, you save the referenced interfaces on the common part. Then, when you place the common part, you only need to select the assembly references.
Understanding Associative Concepts

Creo Parametric is a bi-directionally associative product development tool.

Bi-directional Associativity

Understanding Associative Concepts

Bi-directional associativity means that all changes made to an object in any mode of Creo Parametric are automatically reflected in every related mode.

For example, a change made in a drawing is reflected in the part being documented in the drawing. That same change is also reflected in every assembly using that part model.

It is important to understand that the associativity between different modes is possible because the part shown in a drawing is not copied into the drawing, but rather associatively linked to the drawing. Likewise, an assembly is not a large file containing copies of every part in the assembly, but rather a file containing associative links to every model used in the assembly.

Best Practices

Because drawing and assembly files have associative links to the models contained in them, these objects cannot be opened without the models they contain being present.

In other words, you cannot send your colleague only a drawing file to open, he or she must have the drawing file along with any model referenced in the
drawing. For an assembly, he or she must have the assembly file and all models used in the assembly.

The best method for acquiring all files required for a drawing or assembly is to use the Backup function. With the required top-level drawing or assembly open, click **File > Save As > Save a Backup** and back the files up to a new folder. This will place all the files required to open that top-level drawing or assembly into the new folder.
Understanding Model-Centric Concepts

In Creo Parametric, the model is the center of all downstream deliverables such as drawings, assemblies, molds, analysis, and manufacturing.

Model-Centric

- Assemblies reference the models being assembled.
- The drawing references the model being documented.
- The Finite Element Mesh model references the model being analyzed.
- The mold tool references the model being molded.

Understanding Model-Centric Concepts

In a model-centric product development tool, the design model is the common source for all deliverables making use of that design model. This means that all downstream deliverables point directly to a common design model. The model is referenced as components in assemblies, views in a drawing, the cavity of a mold, geometry meshed in a Finite Element Mesh model, and so on.

Examples of downstream deliverables are:

- Slot car assemblies the wheel is used in, almost every car has wheels.
- The drawing used to document the wheel design, each view is generated from the wheel part.
- The mold tool uses the wheel part to define the geometry of the mold cavity.
- A Finite Element Mesh (FEM) model is created from the wheel part. Engineers use this FEM model to determine the strength of the part, the flow properties of the molded part, and so on.

The benefit of using a model-centric development tool is that a change made to the design model will automatically update all related downstream deliverables.
Understanding the Creo Parametric Interface

The Main Interface includes the following areas:

- Graphics Area
- Quick Access toolbar
- Ribbon
- Dashboard
- Status bar
- Message Log
- Dialog Boxes
- In Graphics toolbar
- Menu Manager

Understanding the Main Interface

There are many different areas of the Creo Parametric user interface that you use when creating models. The areas of the interface displayed depend upon the function being performed. Areas of the main interface include:

- **Graphics area** — The working area of Creo Parametric in which you view, create, and modify Creo Parametric models. This can also be referred to as the Graphics Window.
• **Pop-up menu** — A pop-up menu contains a limited set of actions related to the selected object. To open a pop-up menu, select an object and then right-click to open the pop-up menu.

For example, to delete a feature you would select it, right-click and select Delete from the pop-up menu.

![Pop-up menu example](image)

You must **hold down** the right mouse button to open a pop-up menu.

• **In Graphics toolbar** — Located at the top of the graphics area, the In Graphics toolbar contains commonly used tools and filters for the graphics area display. You can customize the tools and filters displayed in the In Graphics toolbar.

![In Graphics toolbar](image)

• **Quick Access toolbar** — The Quick Access toolbar is located at the top of the interface. It contains a commonly used set of commands that are independent of the tab currently displayed in the ribbon. These commands are available regardless of the specific mode or tab in which you are working. You can customize the Quick Access toolbar to add additional commands.

![Quick Access toolbar](image)

• **Ribbon** — A context-sensitive menu across the top of the interface that contains the majority of the commands you use in Creo Parametric. The ribbon arranges commands into logical tasks through tabs and groups.

![Ribbon](image)
• **Dashboard** — Locked at the top of the user interface, the Dashboard appears when you create or edit the definition of a feature.
  - The Dashboard provides you with controls, inputs, status, and guidance for carrying out a task, such as creating or editing a feature.
  - Various dashboard tabs are available with additional feature options.
  - Dashboard icons on the left include feature controls while the Pause, Preview, Create Feature, and Cancel Feature options are on the right.

• **Dialog Boxes** — Content-sensitive windows which display and prompt you for additional information.

• **Status bar** — Located at the bottom of the interface, the status bar contains icons for toggling the model tree and Web browser panes on and off. It also contains the message log, regeneration manager, 3D box selector, and selection filter.

• **Message Log** — Located at the bottom of the graphics area, the message log provides you with prompts, feedback, and messages from Creo Parametric.
• **Menu Manager** — A cascading menu that appears on the far right during the use of certain functions and modes within Creo Parametric.

In general you work from top to bottom in this menu; however, the workflow for clicking “Done” moves from the bottom to top of the menu.

Bold menu options will be automatically selected if the middle mouse button is clicked.
Working Directories and Saving your Work

The Working Directory is the location for opening files from and saving new files to.

Setting your Working Directory:

• Creo Parametric starts in a start-in folder on your computer, by default, this is your working directory.
• A working directory is the folder you open files from and save files to.
• The working directory is selected before every session. When you exit Creo Parametric, it does not remember the working directory for the next session.

Open Files - The File Open dialog box looks to the working directory.

Save Files - Files are saved to the folder they were opened from, this is not always the working directory.

Working Directory Theory

The working directory is the designated location for opening and saving files. The default working directory is the “Start in” location defined in the Creo Parametric start icon, typically the “My Documents” folder.

If you are not using PTC’s Windchill PDMLink to manage your Creo Parametric data, it is best practice to organize your work by creating a folder for each project. Each time you start Creo Parametric, you should set the working directory to the folder you plan to work in.

There are four methods to set your working directory, use the method you are most comfortable with. You can set your working directory from the:

• Home tab - When Creo Parametric first opens; click Select Working Directory from the Data group of the Home tab.
  This is the easiest and most straight forward method.
• File menu - If the Home tab is not available, click File > Manage Session > Select Working Directory.
• Creo Parametric Folder Tree or Browser - Right-click the folder that is to be the new working directory and select Set Working Directory from the pop-up menu.
• **Creo Prametric File Open dialog box** - Right-click the folder that is to be the new working directory and select **Set Working Directory** from the pop-up menu.

You can browse directly to the working directory at any time by selecting **Working Directory** from the Common Folder list in the Navigator or File Open dialog box.

## Opening Files

After you have set your working directory, you will see the files in that folder each time you click **Open** in Creo Parametric.

You can use any of the following methods to open a file:

- Click **File > Open** from the main menu, click **Open** from the Quick Access toolbar, or click **Open** from the **Home** tab. Then, in the File Open dialog box, you either double-click the file you want to open or select the file and click **Open**.
- Browse to the desired folder using the Navigator (either with Common Folders or through the Folder Tree) to display its contents in the browser. Then, you can either double-click the file in the file list, or right-click the file and select **Open** from the pop-up menu.
- You can also drag the file from browser into the graphics area.

The File Open dialog box is the equivalent of the Navigator and Browser combination in the main interface.

## Saving Files

By default, files are saved to the folder they were opened from. A new part, assembly, or drawing will be saved to the folder that is active when you click **OK** from the Save Object dialog box.

You can use any of the following methods to save a file:

- Click **File > Save** from the main menu.
- Click **Save** from the Quick Access toolbar.
- Use the **CTRL + S** keyboard shortcut.

## Saving a Copy of Files

You can also save a copy of an existing file. Saving a copy enables you to create an exact copy of a file, but with a different name. When saving a copy of an assembly, you must also decide what to do about its dependent components. You can do nothing, or save a copy of them also and either rename them with a suffix or give them all new names.
Managing Files in Creo Parametric

Understanding Creo Parametric’s file types and how they are used will help you manage your design.

Common File Extensions

- .prt – Part Files
- .asm – Assembly Files
- .drw – Drawing Files

Memory Management

- An open object is In Session.
- Erasing Memory (RAM)

Version Numbers and Deleting

- Version Numbers increase by one each time you save.
- Delete All or Old Versions

Renaming Models

- Rename On Disk and In Session
- Rename In Session

Common File Extensions

The following are three file extensions used to identify three common Creo Parametric object types; parts, assemblies, and drawings.

- .prt — This extension represents a part object.
- .asm — This extension represents an assembly object. An assembly file contains pointers and instructions that identify and position a collection of parts and subassemblies.
- .drw — This extension represents a 2-D drawing. The drawing file contains pointers, instructions, and detail items for documenting part and assembly models in a drawing.

Version Numbers and Deleting

Every time you save an object, you write it to disk. Rather than overwriting the current file, Creo Parametric creates a new version of the file on disk and gives it a version number that increments each time the file is saved. This is also known as a “dot number”, and can be seen in the figure above.

To see all versions of an object in the File Open dialog box, click Tools and select All Versions from the drop-down list.

Deleting files permanently removes them from the working directory on your hard drive or network storage area. Be careful when deleting files; you cannot undo deleted files.
There are two different methods to delete models:

- **Old Versions** — Deletes all but the latest version of the given file.
- **All Versions** — Deletes all versions of the given file.

### Memory Management

Creo Parametric is a memory-based system, which means that files you create and open are temporarily kept in system memory (RAM). It is important to remember that until you save your files, you risk losing them if there is a power outage or system crash.

When a model is in system memory, it is referred to as being *In Session*. Models are kept In Session (in system memory or RAM) until you either erase them or exit Creo Parametric.

When you close the window that contains a model, the model is still open In Session.

There are two different methods to erase models from session:

- **Erase Current** — Only the model in the current window is erased from system memory (and the window closed). You can click File > Manage Session > Erase Current from the main menu to erase the current window's contents from memory.
- **Erase Not Displayed** — Only erases from memory those models that are not open in any Creo Parametric windows. You can click File > Manage Session > Erase Not Displayed from the main menu or Erase Not Displayed from the Data group of the Home tab.

Erasing models does not delete them from the hard drive or network storage area; it only removes them from session.

### Renaming Models

If you need to change the name of any model, you can rename it directly within Creo Parametric.

To rename a file, click File > Manage File > Rename, then in the Rename dialog box, choose one of the two different methods:

- **On Disk and In Session** — The system renames the file both in system memory and on the hard drive.
- **In Session** — The system renames the file only in system memory.

Problems can result if you rename a file on disk and then retrieve a model (not already in session) that depends on the previous file name. For example, if you rename a part, any assemblies that the part is used in will no longer be able to find it, unless those assemblies were open when the part was renamed and then saved after it was renamed.
PROCEDURE - Managing Files in Creo Parametric

Scenario
Erase files from memory and rename a part.

**Step 1:** Set your working directory.

1. If necessary, start Creo Parametric 2.0.
2. From the **Home** tab, **Data** group, click **Select Working Directory**.
3. In the Select Working Directory dialog box:
   - Navigate to the folder **Creo2_Adv_Primer**.
   - Double-click the folder **Module_01**.
   - Double-click the folder **Workdir**.
   - Click **OK** to set the folder as your working directory.
4. From the Quick Access toolbar or the **Home** tab, click **Open**.

In the File Open dialog box, notice that each file has an extension signifying that it is a part (.prt), assembly (.asm), drawing (.drw) or format (.frm) type file.

5. In the File Open dialog box:
   - In the address bar at the top of the dialog box, click **Creo2_Adv_Primer** to look in that folder.
   - Browse into other folders on the computer but do not open any files.
   - In the **Common Folders** list, click **Working Directory**.

No matter where you or a student have browsed to, one click of **Working Directory** will return you to the working directory.
Step 2: Open, save, and observe the version number changes.

1. In the File Open dialog box:
   - Click **Tools** and select **All Versions** from the drop-down list.
   - Observe the different version numbers associated with each file.
   - Note that WHEEL.PRT has been saved three times.
   - Click **Tools** and disable **All Versions**.
   - Select WHEEL.PRT and click **Open** to open the last saved version.

2. If necessary, from the In Graphics toolbar, click **Datum Display Filters** and disable the display of all datum features.

3. From the Quick Access toolbar, click **Save**.

4. From the Quick Access toolbar, click **Open**.

5. In the File Open dialog box:
   - Click **Tools** and enable **All Versions**.
   - Observe that a new version, WHEEL.PRT.4 has been saved.
   - Click **Cancel** to close the dialog box.
Step 3: Edit the model and then erase it from session.

1. In the model tree, right-click (and hold down) on the **Extrude 1** feature and then select **Edit** from the pop-up menu:
   - Double click the dimension value 17.6, edit the value to **25** and press ENTER.
   - From the Quick Access toolbar, click **Regenerate**.

2. Click **Open** and in the File Open dialog box:
   - In the **Common Folders** list, click **In Session**.
   - Observe WHEEL.PRT is the only model in session (or in memory).
   - **Use In Session** to open a model that has not been saved.

3. From the Quick Access toolbar, click **Close Window**.

4. Click **Open** and in the File Open dialog box:
   - In the **Common Folders** list, click **In Session**.
   - Observe WHEEL.PRT is still in session (or in memory).
   - Click **Cancel** to close the dialog box.
You have just proved that closing a window does not erase the model from memory, only from display.

5. Click **File > Manage Session > Erase Not Displayed**:
   - In the Erase Not Displayed dialog box, click **OK**.

6. Click **Open** and in the File Open dialog box:
   - Click **In Session**.
   - Observe that WHEEL.PRT is no longer in session.
   - Click **Working Directory**.
   - Double-click WHEEL.PRT to open the last saved version.

The change you previously made is no longer visible because you erased that version from memory before saving it. You are now looking at WHEEL.PRT.4 which you saved before the change was made.

**Step 4:** Rename WHEEL.PRT to be WHEEL-NEW.PRT.

1. Click **Open** and in the File Open dialog box, double-click WHEEL.ASM:
   - In the model tree, notice that WHEEL.PRT and TIRE.PRT are listed as members of the assembly.
Both WHEEL.PRT and WHEEL.ASM are open in Creo windows. Because it was opened last, WHEEL.ASM is currently in the active window. Use Windows to activate the window containing WHEEL.PRT.

2. From the Quick Access toolbar, click Windows and select 1 WHEEL.PRT from the drop-down menu to activate it.

3. Click File > Manage File > Rename:
   - In the New Name text box, type wheel-new.
   - Click OK to complete the rename.

4. From the Quick Access toolbar, click Windows and enable 2 WHEEL.ASM from the drop-down menu to activate it:
   - In the model tree, notice that the renamed model WHEEL-NEW.PRT is now listed as a component of the assembly.

Before renaming the wheel, it was important that WHEEL.ASM was open (In Session). Had it not been open, it would not have known that the name of the wheel had changed. It is also important that WHEEL.ASM be saved with this new information.
5. From the Quick Access toolbar, click **Save**.

6. Click **Open** and in the File Open dialog box:
   - Observe that WHEEL.PRT has been renamed to WHEEL-NEW.PRT.
   - Click **Tools** and enable **All Versions**.
   - Observe that because you saved the assembly, the latest versions is now WHEEL.ASM.3.
   - Click **Cancel** to close the dialog box.

![File Open dialog box](image)

7. Close all open windows and erase the files from session:
   - From the Quick Access toolbar, click **Close Window** to close the WHEEL.ASM window.
   - Click **Close Window** again, this time to close WHEEL-NEW.PRT.
   - From the **Home** tab, **Data** group, click **Erase Not Displayed**:
     - In the Not Displayed dialog box, click **OK**.

This completes the procedure.
Understanding Datum Display Options

You can independently control the display of datum entities and datum tags in the graphics area.

- **Datum entities include:**
  - Datum Axes
  - Datum Points
  - Coordinate Systems
  - Datum Planes

- **Datum tags include:**
  - Plane Tag Display
  - Axis Tag Display
  - Point Tag Display
  - Csys Tag Display

Setting Datum Display

Datum entities are 3-D reference geometry that you use for building feature geometry, orienting models, dimensioning, measuring, and assembling.

There are four main datum types:

- Datum Axes
- Datum Points
- Coordinate Systems
- Datum Planes

The display of each of these datum types is controlled independently using the following icons from either the Show group of the View tab or from the Graphics toolbar:

- **Axis Display** — Enable/Disable datum axis display.
- **Point Display** — Enable/Disable datum point display.
- **Csys Display** — Enable/Disable datum coordinate system display.
- **Plane Display** — Enable/Disable datum plane display.
Setting Datum Tag Display

Each datum entity has a name associated with it, for example, datum plane FRONT. Using the Academic Program configuration of Creo Parametric, datum names are displayed in both the model tree and in the graphics area.

The display of each datum tag type can be controlled independently using icons from the Show group of the View tab.

- **Plane Tag Display** — Enable/disable display of datum plane tags.
- **Axis Tag Display** — Enable/disable display of datum axis tags.
- **Point Tag Display** — Enable/disable display of datum point tags.
- **Csys Tag Display** — Enable/disable display of datum coordinate system tags.
PROCEDURE - Understanding Datum Display Options

Scenario
Edit the datum feature displays.

Step 1:  Set your working directory.

1. If necessary, start Creo Parametric 2.0.
2. From the Home tab, Data group, click Select Working Directory.
3. In the Select Working Directory dialog box:
   • Navigate to the folder Creo2_Adv_Primer.
   • Double-click the folder Module_01.
   • Double-click the folder Datum_Display.
   • Click OK to set the folder as your working directory.

Step 2:  Open TIRE.PRT and edit the datum display.

1. From the Quick Access toolbar, click Open:
   • In the File Open dialog box, select TIRE.PRT and click Open.
2. If necessary, from the In Graphics toolbar, click Datum Display Filters and enable the display of all datum features.
3. From the In Graphics toolbar, click Datum Display Filters and enable the display of only datum axis.
4. Click **Datum Display Filters** and enable the display of only datum points.

5. Click **Datum Display Filters** and enable the display of only coordinate systems.

6. Click **Datum Display Filters** and enable the display of only datum planes.
7. Click **Datum Display Filters** and disable the display of all datum features.

8. Erase the model from session:
   - Click **File > Manage Session > Erase Current**.
   - In the Erase Confirm dialog box, click **Yes**.

This completes the procedure.
Understanding Display Style Options

You can modify the display style of models in the graphics area.

- **Display style options:**
  - Shading With Edges
  - Shading With Reflections
  - Shading
  - No Hidden
  - Hidden Line
  - Wireframe

- **Repaint** – Redraws or refreshes the graphics area.

Understanding Display Style Options

There are six different display style options in the graphics area. These options can be selected from the In Graphics toolbar:

- **Shading With Edges** – The model is shaded and its edges are highlighted.

- **Shading With Reflections** – Shadows and a reflection are laced on an imaginary floor directly below the model.

- **Shading** – The model is shaded without the edges being highlighted.

- **No hidden** – Hidden lines in the model are not displayed.

- **Hidden Line** – Hidden lines in the model are displayed in a slightly darker color than visible lines.

- **Wireframe** – Hidden lines are displayed as regular lines. That is, all lines in the front or back of the model have the same color and weight.

Repainting the Graphics Area

You can repaint a view to remove all temporarily displayed information. Repainting redraws or refreshes the graphics area, and is performed by clicking **Repaint** from the In Graphics toolbar.
PROCEDURE - Understanding Display Style Options

Scenario
Edit the model display style options.

Step 1: Set your working directory.

1. If necessary, start Creo Parametric 2.0.
2. From the Home tab, Data group, click Select Working Directory.
3. In the Select Working Directory dialog box:
   • Navigate to the folder Creo2_Adv_Primer.
   • Double-click the folder Module_01.
   • Double-click the folder Display_Style.
   • Click OK to set the folder as your working directory.

Step 2: Open DISPLAY_STYLE.ASM and edit the datum display.

1. From the Quick Access toolbar or the Home tab, click Open.
   • In the File Open dialog box, select DISPLAY_STYLE.ASM and click Open.
2. If necessary, from the In Graphics toolbar, click Datum Display Filters and disable the display of all datum features.
Step 3: Edit the display style of the model.

1. If necessary, from the In Graphics toolbar, select **Shading With Edges** from the Display Style types drop-down menu.
   - This is the default display type if Creo Parametric is configured using the Academic Program configuration. The model is shaded and model edges are highlighted in black.

2. From the In Graphics toolbar, select **Shading With Reflections** from the Display Style types drop-down menu.
   - Lighting has been applied to the model and it is reflected in the floor.

3. Select **Shading** from the Display Style types drop-down menu.
   - The model is shaded but the edges are not highlighted.

4. Select **No hidden** from the Display Style types drop-down menu.
   - The model is not shaded and hidden edges are not displayed.
5. Select **Hidden Line** from the Display Style types drop-down menu.

   Hidden edges are displayed in a lighter gray color to signify they are hidden behind geometry.

6. Select **Wireframe** from the Display Style types drop-down menu.

   All lines are displayed using a wireframe display.

7. Close the window and erase the open files from session:
   - From the Quick Access toolbar, click **Close Window**.
   - From the **Home** tab, **Data** group, click **Erase Not Displayed**:
     - In the Erase Not Displayed dialog box, click **OK**.

This completes the procedure.
Using Spin, Pan, Zoom and Named Views

Manipulate the 3-D orientation of your design models in the Creo Parametric graphics area.

Keyboard/Mouse Orientation:

• Spin
• Pan
• Zoom
• Turn
• Wheel Zoom

In Graphics Toolbar Options:

• Previous
• Refit
• Named Views
• Spin Center

Orientation using Keyboard and Mouse Combinations

To view a model in a specific orientation, you can spin, pan, and zoom the model using a combination of keyboard and mouse functions. For each orientation, you press and hold a key while pressing and holding the appropriate mouse button, as shown in the following table.

<table>
<thead>
<tr>
<th>Orientation</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spin</td>
<td></td>
</tr>
<tr>
<td>Pan</td>
<td></td>
</tr>
<tr>
<td>Zoom</td>
<td></td>
</tr>
<tr>
<td>Turn</td>
<td></td>
</tr>
</tbody>
</table>
Cursor over the area of interest before zooming in. The zoom function uses the cursor position as its area of focus. You can also zoom by using the scroll wheel. To control the level of zoom, press a designated key while using the scroll wheel, as shown in the following table:

<table>
<thead>
<tr>
<th>Zoom Level</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom</td>
<td>![Zoom Icon]</td>
</tr>
<tr>
<td>Fine Zoom</td>
<td>![Fine Zoom Icon]</td>
</tr>
<tr>
<td>Coarse Zoom</td>
<td>![Coarse Zoom Icon]</td>
</tr>
</tbody>
</table>

**In Graphics Toolbar and View Tab Orientation Options**

In addition to using keyboard and mouse combinations, the following additional model orientation options are available:

- **Previous** - Revert the model to the previously displayed orientation by clicking Previous from the Orientation group of the View tab.

- **Refit** — Refit the entire model in the graphics area.

- **Named Views** — Display a list of saved view orientations available for a given model. Select the name of the desired saved view, and the model reorients to the selected view. The Academic Program template models come with the following saved views:
  - **Standard Orientation** — The initial 3-D orientation which cannot be altered.
  - **Default Orientation** — Similar to the Standard Orientation, but its orientation can be redefined to a different orientation.
  - BACK, BOTTOM, FRONT, ISOMETRIC, LEFT, RIGHT, TOP and TRIMETRIC.

- **Spin Center** — Enables and disables the spin center. When enabled, the model spins about the location of the spin center. When disabled, the model spins about the cursor location. Disabling the spin center can be useful when orienting a long model, like a shaft.
### Scenario
Practice orienting a model in the graphics area using saved views, the spin center, and basic keyboard and mouse model orientation.

#### Step 1: Set your working directory.

1. If necessary, start Creo Parametric 2.0.
2. From the **Home** tab, **Data** group, click **Select Working Directory**.
3. In the Select Working Directory dialog box:
   - Navigate to the folder **Creo2_Adv_Primer**.
   - Double-click the folder **Module_01**.
   - Double-click the folder **Spin**.
   - Click **OK** to set the folder as your working directory.

#### Step 2: Open CHASSIS.ASM, disable datum display and orient the model.

1. From the Quick Access toolbar, click **Open**:
   - In the File Open dialog box, select CHASSIS.ASM and click **Open**.
2. If necessary, from the In Graphics toolbar, click **Datum Display Filters** and disable the display of all datum features.
3. From the In Graphics toolbar, click **Named Views** and select **TOP** from the drop-down menu.
4. From the In Graphics toolbar, click **Named Views** and select **LEFT** from the drop-down menu.

5. Click **Named Views** and select **Default Orientation**.

**Step 3:** Orient with the spin center on and then off.

1. Middle-click and drag to spin the assembly:
   - Spin the assembly again, to a different orientation.
   - Spin the assembly to a third orientation.

   ![The assembly is spinning about the Spin Center](image)

2. Click **Named Views** and select **Standard Orientation**.

3. From the In Graphics toolbar, disable **Spin Center**:
   - Move your cursor over the front of the chassis assembly and spin the model.

   ![Notice that the model now spins about your cursor location, not the center of the model.](image)

4. In the ribbon, select the **View** tab:
   - From the **Orientation** group, click **Previous**.

5. Move your cursor over the back of the chassis assembly and spin the model.

6. From the In Graphics toolbar, enable **Spin Center**.
Step 4: Pan the assembly.

1. Press and hold **SHIFT** while you middle-click and drag to pan the model about the graphics area.
2. Click **Named Views** and select **Standard Orientation**.

Step 5: Zoom in and out of the assembly.

1. Press and hold **CTRL** while you middle-click and drag upward to zoom out.
2. Press and hold **CTRL** while you middle-click and drag downward to zoom in.
3. If your mouse is equipped with a wheel:
   - Roll the mouse wheel away from you to zoom out.
   - Roll the mouse wheel towards you to zoom in.

   The zoom function uses the cursor position as the center of zoom. Because of this, be sure to place your cursor over the area of the model you wish to zoom in to.

4. Click **Named Views** and select **Standard Orientation**.
5. Move your cursor over the motor, then press and hold **CTRL** while you middle-click and drag downward to zoom in on the motor.

   If you have a middle mouse wheel, you will most likely prefer to zoom in and out using that method.
6. From the In Graphics toolbar, click Refit.

7. Close the window and erase the open files from session:
   - Click File > Manage Session > Erase Current.
   - In the Erase dialog box, click **Select All** and click **OK** to erase all components of the assembly.

This completes the procedure.
Selecting Items using Direct Selection

Direct selection occurs when you place the mouse cursor over a component, feature or geometry and click to select.

You can direct select:

- Components
- Features
- Geometry (by pressing ALT)

Perform direct selection in:

- The graphics area
- The model tree

Select multiple items using CTRL.

Select a range of items using SHIFT.

**Select Components in Model Tree or Graphics Area**

Select Features in Model Tree or Graphics Area

Press ALT and select surfaces, edges and vertices directly

---

Selecting Items using Direct Selection

After selecting components, features or geometry in a part, assembly, or drawing, you are able to perform actions on those selected items.

Direct selection occurs when you place your cursor over a component, feature or geometry and click to select it. Some key factors about direct selection include:

- You can perform direct selection of components in an assembly, and features or geometry of a part.
- You can perform direct selection in both the graphics area and in the model tree.
- When you initially cursor over a model in the graphics area, the component or feature highlights in a transparent green color. When you select the item, it becomes highlighted in green wireframe.

The selected item is dependent on whether you have a part or assembly open:

- If you have a part open, a selected feature highlights in a green wireframe.
- If you have an assembly open, the selected component highlights in a green wireframe.
• In a part or assembly, you can select surfaces, edges or vertices directly by pressing ALT when selecting. The selected geometry will highlight in a green wireframe.

• You can select multiple items by pressing CTRL when selecting.

• You can select a range of items from the model tree using the SHIFT key. If you select an item, press SHIFT and select a second item, the entire range of items in between is also selected.

• You can de-select components or features three different ways:
  – Press CTRL and click the selected item again.
  – Click in and empty space in the graphics area.
  – Right-click the selected items area at the lower-right of the interface and select Clear from the pop-up menu.
Understanding Selection Filters

The selection filter provides various filters to help you select items.

**Filters include:**

- Parts
- Features
- Geometry
- Datums
- Quilts
- Annotation
- Smart

The Selection Filter

**Understanding Selection Filters**

Each filter in the selection filter narrows the item types that you can select, enabling you to easily select the item you are looking for. All filters are context-sensitive, so that only those filters that are valid for the geometrical context are available.

For example, the Parts filter would not be available while working in a part; rather it would be available while working in an assembly. Creo Parametric automatically selects the best filter according to the context. However, you can always change the filter by simply selecting it from the selection filter drop-down menu.

The following filters are available in Part mode and Assembly mode:

- Parts — Available in Assembly mode only, enables you to only select components in the assembly.
- Features — Enables you to only select features in a part or component in the assembly.
- Geometry — Enables you to only select geometry, such as edges, surfaces, and vertices.
- Datums — Enables you to only select datum features, including datum planes, datum axes, datum points, and coordinate systems.
- Quilts — Enables you to only select surface quilts.
- Annotation — Enables you to only select annotation features.
- Smart — Enables you to select features, geometry, or components using a nested selection process.
Using the Smart Selection Filter

The smart filter enables you to select the most common types of items that are valid for the current geometrical context.

Smart Filter:

- The selection of features, geometry, or components is a nested process.
- Select specific items of interest after the initial selection.

**Smart filter selection levels:**

- Feature/Component level.
- Geometry level (surfaces, edges, or vertices).
  - You may need to zoom in for surface selection.
  - Press ALT to automatically go to the Geometry selection level.

Using the Smart Selection Filter

Creo Parametric automatically uses the Smart selection filter. When using the Smart selection filter, the selection of features, geometry, or components is a nested process. This means you can select specific items of interest after the initial selection. There are two levels of selection when using the Smart Filter:

- **Feature/Component Level** – The features that comprise a part or components that comprise the assembly.
- **Geometry Level** – The surfaces, edges, and vertices (endpoints of edges) that comprise the model geometry.

When selecting a part in the graphics area, your initial selection highlights a feature in a green wireframe. The Smart selection filter then automatically narrows the selection scope, enabling you to select specific items on that feature that you wish to either modify or use to create another feature.

For example, you can select an edge where you wish to add a chamfer.

![Image](image.png)

If you press and hold the ALT key, you are automatically moved to the geometry level filter.

The three specific geometric entities that you may wish to select highlight differently, as shown in the figure. Selected surfaces highlight as green shaded items; selected edges highlight in bold green; and selected vertices highlight in green. The entire filtering process occurs automatically.
Assemblies have a similar selection scheme. Components are selected initially, followed by geometry such as surfaces, edges, and vertices.

Selection of items usually occurs easier if you zoom in on that area of the model first.
PROCEDURE - Using the Smart Selection Filter

Scenario
Use the smart selection filter in an assembly and part model.

Step 1: Set your working directory and open SMART.ASM.

1. If necessary, start Creo Parametric 2.0.
2. From the Home tab, Data group, click Select Working Directory.
3. In the Select Working Directory dialog box:
   • Navigate to the folder Creo2_Adv_Primer.
   • Double-click the folder Module_01.
   • Double-click the folder Smart.
   • Click OK to set the folder as your working directory.
4. From the Quick Access toolbar, click Open:
   • In the File Open dialog box, select SMART.ASM and click Open.

Step 2: Use the smart selection filter in an assembly.

1. If necessary, from the In Graphics toolbar, click Datum Display Filters, and disable the display of all datum features.
2. In the graphics area, select the component CHASSIS_SIDE-GEARS.PRT, as shown highlighted in green.
3. Zoom in on the small hole in the lower-left side of the part:
   • Select the planar surface closest to you, as shown in green.

4. Select the cylindrical surface in the hole.

5. Select the edge of the hole.

6. Select the vertex (endpoint) on the edge of the hole.

7. Click in an empty space in the graphics area to de-select the vertex.
Step 3: Use the smart selection filter in a part model.

1. Press **CTRL + D** to orient the assembly to the standard orientation.
2. In the graphics area, select the screw named M4–MACH_SCREW.PRT, then right-click, and select **Open** from the pop-up menu.

3. Select the top of the screw head to select the feature named Extrude 1:
   - With Extrude 1 selected, select the front cylindrical surface of the screw head.
4. Click in an empty space in the graphics area to de-select the surface.

5. Press and hold the **ALT** key, then select the top edge of the slotted extrude feature.

   **Pressing the ALT key enables you to bypass smart selection and select model geometry without first selecting a feature.**

6. Close the M4–MACH_SCREW.PRT window and erase the open files from session:
   - From the Quick Access toolbar, click **Close Window**.
   - Click **File > Manage Session > Erase Current**.
   - In the Erase dialog box, click **Select All**, then click **OK** to erase all components of the assembly.

This completes the procedure.
Selecting Items using Query Selection

Query selection enables selection of features, geometry, or components that are hidden beneath another item.

**Query Selection:**

- Select by querying the model.
- Select using the Pick From List.

**Selecting Items using Query Selection**

Query selection enables you to select features, geometry, or components that are hidden beneath another feature or model.

For example, in the figure shown, you may want to select the screw but the other models are obstructing your attempts to select it. In this situation, you can easily query and select the screw.

**Query the Model**

Use the following steps to query through components of an assembly or features of a part:

- Move your cursor over a component or feature in the graphics area and it will turn a transparent green color, highlighting the preselected item. Preselected means that if you click at that moment, that is what will be selected (and turn to a green wireframe highlight).
- Right-tap (do not right-click and hold) the preselected model or feature to query directly through the initial model or feature to the next model or feature under the cursor. You can continue to right-tap to query the next model or feature.
• When you have queried to the desired model or feature, you then click to select it.

Cursor over to highlight, right-tap to query, and click to select.

Pick From List

The Pick From List is similar to querying the model, except that all of the query possibilities are listed in the Pick From List dialog box. This method is most useful in very large assemblies or complicated parts:

• Activate Pick From List by moving your cursor over the location you want to query, then right-click and select Pick From List from the pop-up menu.
• As you select items in the Pick From List dialog box, they will be highlighted in the graphics area.
• Select the item you want to select from the Pick From List dialog box, then select OK to make the selection.
PROCEDURE - Selecting Items using Query Selection

Scenario
Use query selection in an assembly and part model.

Step 1: Set your working directory and open QUERY.ASM.

1. If necessary, start Creo Parametric 2.0.
2. From the Home tab, Data group, click Select Working Directory.
3. In the Select Working Directory dialog box:
   • Navigate to the folder Creo2_Adv_Primer.
   • Double-click the folder Module_01.
   • Double-click the folder Query.
   • Click OK to set the folder as your working directory.
4. From the Quick Access toolbar, click Open:
   • In the File Open dialog box, select QUERY.ASM and click Open.

Step 2: Use query to select the screw hidden behind other components.

1. If necessary, from the In Graphics toolbar, click Datum Display Filters, and disable the display of all datum features.

You will use Query to select components and features that are hidden behind other components and geometry, without spinning your model to see them.

2. Move your cursor over the center of assembly.

© 2009 PTC
3. Right-click to query (tap your right-mouse button) until SCREW_NO2_SHLDR.PRT highlights, then left-click to select it.

If you right-click and hold your mouse down, you will open a pop-up menu. To use query, just tap the right mouse button.

4. With the screw selected, right-click in the graphics area and select Open from the pop-up menu.

5. From the Quick Access toolbar, click Close Window.

Step 3: Use Pick From List to select a feature hidden behind geometry in a model.

1. Move your cursor over SG_SLOT.PRT and click to select it.

Query is not required here because the part is not hidden behind another part.

2. With SG SLOT.PRT selected, right-click in the graphics area and select Open from the pop-up menu.
3. Move your cursor over the top cylindrical surface as shown in the image:
   - Without moving your mouse, right-click and select **Pick From List** from the pop-up menu.

4. In the Pick From List dialog box, select the feature named F33(REVOLVE_4).

   To see this feature in the Pick From List dialog box, your cursor must be over the feature when you right-click and select **Pick From List**. In the image below, you can see where the feature is located.

5. From the Pick From List dialog box, click **OK**.

6. Click in an empty space in the graphics area to de-select the feature.

---

**Step 4:** Use query to select the same feature F33(REVOLVE_4).

1. Move your cursor over the top of the cylindrical surface, where the F33(REVOLVE_4) feature is located:
   - Without moving your mouse, right-tap until feature F33(REVOLVE_4) highlights, then left-click to select it.

2. Notice that the selected feature also highlights in the model tree.

   **Cursor over to highlight, right-tap to query, and click to select.**
3. Close the window and erase open files from session:

- From the Quick Access toolbar, click Close Window.
- Click File > Manage Session > Erase Current.
- In the Erase dialog box, click Select All, then click OK to erase all components of the assembly.

This completes the procedure.
Understanding the Basics of Sketcher

A good understanding of sketcher concepts such as sketch plane, orientation, and references will make you a better Creo Parametric user.

**Section Orientation:**
- Set horizontal reference
- Set vertical reference
- Flip section orientation
- Flip sketching plane

Click **Sketch Setup** from the Setup group.

**Sketcher References:**
- Sketcher Geometry Snaps to References
- Any Model Geometry Selected in Sketcher

**Adding Additional References**
- Click **References** from the Setup group.
- Press the ALT key.

**Section Orientation**

A sketch is most commonly used to define the shape of an extrude or revolve feature. In those features, the sketch defines the shape you will extrude or revolve.

Before you can start sketching a shape, you must first select the plane you will sketch on, this plane is called the Sketch Plane.

- **Sketch Plane** — You can select any datum plane or planar surface to be your sketch plane. In the 2-D sketch view, the sketch plane will be oriented parallel to your screen. You can select the sketch plane before or after you start the extrude or revolve tool.

- **Section Orientation** — Based on the current orientation of your model, Creo Parametric will automatically define a 2-D sketch view for the sketch. To reorient the 2-D sketch view, right-click in the graphics area and select one of the following options from the pop-up menu:
  - **Set horizontal reference** — Select a reference on the model to be oriented horizontally.
  - **Set vertical reference** — Select a reference on the model to be oriented vertically.
  - **Flip section orientation** — Rotates the model 180 degrees, normal to the sketch plane.
– **Flip sketching plane** — Rotates the model 180 degrees about the horizontal.

**Sketch Setup**

You can open the Sketch dialog box by clicking **Sketch Setup** from the Setup group. From the Sketch dialog box, you can select a new sketch plane and/or reorient the sketch view:

- **Sketch Plane** — You can select a new sketch plane.
- **Orientation** — The orientation direction that the Reference faces is either **Top**, **Bottom**, **Left** or **Right**.
- **Flip** — The **Flip** button will reorient your sketch so that you are viewing it from the other side. The view is rotated 180 degrees about a vertical axis.
- **Use Previous** — The **Use Previous** button is a big time saver when you are creating multiple features on the same sketch plane. Clicking it enables you to use the sketch plane and orientation of the previous sketch.

**Sketcher References**

You use sketch reference to snap sketch geometry to. For example if you want the center of a circle on the edge of a model, you snap to that edge rather than dimensioning the circle to the edge. This eliminates extra dimension and adds intent to your design.

Sketch references are also used by the system for creating the initial weak dimensions and constraints applied when you sketch geometry.

Sketch references appear as blue, dashed entities in sketcher. Typically, the system automatically creates a vertical and horizontal reference using the default datum planes in the model.

**Adding Additional Reference**

Any time you are in sketcher, you can add additional references:

- To open the References dialog box, click **References** from the Setup group of the Sketch tab.
- With a sketcher tool such as Rectangle or Circle active, you can press the ALT key and select a reference from the model.
PROCEDURE - Understanding the Basics of Sketcher

Scenario
A sketch is most commonly used to define the shape of an extrude or revolve feature. It defines the shape you will extrude or revolve. In this exercise you will learn to select and orient a sketch plane and then select sketcher references to help define your sketch.

Step 1: Set your working directory and open SKETCH.PRT.

1. If necessary, start Creo Parametric 2.0.
2. From the Home tab, Data group, click Select Working Directory.
3. In the Select Working Directory dialog box:
   - Navigate to the folder Creo2_Adv_Primer.
   - Double-click the folder Module_01.
   - Double-click the folder Sketch.
   - Click OK to set the folder as your working directory.
4. From the Quick Access toolbar, click Open:
   - In the File Open dialog box, double–click SKETCH.PRT.
5. From the In Graphics toolbar, click Datum Display Filters and disable the display of all datum features except datum planes.
Step 2: Start the Extrude tool, then select and orient the sketch plane.

1. If necessary, press **CTRL + D** to reorient the model to its default orientation.

2. From the Model tab, Shapes group, click **Extrude**:  
   - In the graphics area, click to select the front surface of the model, as shown in green.

Think of the sketch plane as a piece of paper you will be sketching on. Immediately after selecting it, the green highlight will disappear and the Sketch tab will open, presenting you with a variety of sketching tools.

You can sketch in a 3-D orientation, however for beginners, it is often easier to sketch with the sketch plane parallel to your screen in the 2-D sketch view:

3. From the In Graphics toolbar, click **Sketch View**.

When you clicked **Sketch View**, the sketch plane was reoriented parallel to the screen. To further control the orientation of the sketch view, Creo has automatically selected the datum plane named TOP and oriented it to face the top of the screen.

4. Press **CTRL + D** to put the model back in a 3-D orientation:  
   - From the In Graphics toolbar, click **Sketch View** to return to the 2-D sketch view.

5. It is often easier to sketch when the model is not shaded:  
   - From the In Graphics toolbar, select **Hidden Line** from the Display Style types drop-down menu.
6. From the In Graphics toolbar, click **Datum Display Filters** and disable the display of all datum features.

**Step 3:** Change the orientation of the sketch view.

In most cases, the default 2-D sketch view orientation is acceptable. If not, you can reorient it using the following options:

- **Set horizontal reference** — Select a reference on the model to be oriented horizontally.
- **Set vertical reference** — Select a reference on the model to be oriented vertically.
- **Flip section orientation** — Rotates the model 180 degrees, normal to the sketch plane.
- **Flip sketching plane** — Rotates the model 180 degrees about the horizontal.

1. Rotate the sketch view so it is 180 degrees about the horizontal:
   - Right-click in the graphics area and select **Section Orientation > Flip sketching plane** from the pop-up menu:
Step 4: Sketch a 7 by 25 rectangle in the upper-left corner of the part.

Sketch a rectangle attached to the upper-left corner of the part. The size of the rectangle will be defined using dimensions.

1. In the Sketching group, select Corner Rectangle from the Rectangle types drop-down menu.
   - Move your cursor over the blue horizontal and vertical reference lines. Notice the cursor snaps as you pass over the reference lines.
   - Click at X1 to snap the start point of the rectangle to the intersection of the blue reference lines.
   - Drag your mouse and click at X2 to complete the rectangle.
     The actual size you sketch your rectangle is not important because it can be resized later.
   - Drag your mouse away from the rectangle and middle-click near X3 to release the rectangle tool.

![Rectangle sketch](image)

2. Resize the rectangle:
   - Click and drag the edges of the rectangle to change its size.
   - Double-click the value of the vertical dimension, edit it to 7 and press ENTER.
   - Double-click the value of the horizontal dimension, edit it to 25 and press ENTER.

![Resized rectangle](image)

Only two of the rectangle’s edges will move because the other two are constrained to the blue reference lines.
Step 5: Re-sketch the rectangle using references to define its size.

<table>
<thead>
<tr>
<th>Sketch the rectangle again, this time controlling its size by referencing a vertex and edge on the part.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the Quick Access toolbar, click <strong>Undo</strong> a few times, until the rectangle is gone.</td>
</tr>
<tr>
<td>Make sure the display of all datum features are disabled.</td>
</tr>
<tr>
<td>2. Select <strong>Corner Rectangle</strong> from the Rectangle types drop-down menu.</td>
</tr>
<tr>
<td>3. Select two extra sketcher references to define the size of your rectangle:</td>
</tr>
<tr>
<td>• Press the <strong>ALT</strong> key and select the vertex at the end of the hidden line shown at <strong>X1</strong>.</td>
</tr>
<tr>
<td>• Release the <strong>ALT</strong> key.</td>
</tr>
<tr>
<td>• Press the <strong>ALT</strong> key and select the horizontal edge shown at <strong>X2</strong>.</td>
</tr>
<tr>
<td>• Release the <strong>ALT</strong> key.</td>
</tr>
</tbody>
</table>
4. With the Corner Rectangle tool still active:
   - Click at X1 to snap the start point of the rectangle to the intersection of the reference lines.
   - Drag your mouse down and to the right.
   - When the right-side of the rectangle is snapped to both the vertex reference shown at X2 and the horizontal reference shown at X3, click to place it.
   - Middle-click near X4 to release the rectangle tool.

When sketched correctly, your sketch will have no weak dimensions because its size is defined by the selected references. If this did not work for you, Undo a few times and try again.

5. When finished sketching, in the Close group, click OK.

Step 6: Define additional options to complete the definition of the extrude.

1. Press CTRL + D.
2. From the In Graphics toolbar, select Shading With Edges from the Display Style types drop-down menu.
3. Spin the model so that you can see the bottom of the part as shown.
4. Click and drag the depth drag handle (small white square) into the model so that it will remove material from the model.

Remove Material can also be toggled on and off in the dashboard.

5. From the dashboard above the graphics area:
   • Click Blind and select Through All from the Depth types drop-down menu.
   • Click Complete Feature to complete the feature.

By using the Through All depth option, you have added design intent to your part. No matter how wide the part becomes, the extrude will always intersect the entire depth of the part.

Step 7: Move the sketch plane to datum plane FRONT.

1. Press CTRL + D.
2. In the model tree, right-click Extrude 4 and select Edit Definition from the pop-up menu:
   • Right-click and select Edit Internal Sketch to open the Sketch tab.
3. From the Setup group, click Sketch Setup:
   • In the model tree, select datum plane FRONT.
   • Notice in the Sketch dialog box that the sketch plane is now datum plane FRONT.
   • Click Sketch to close the dialog box.
4. Spin the model so you can see that the sketch has moved from the front face of the model to datum plane FRONT at the center of the model.

5. From the Close group, click OK.

6. Spin the model so you can see how Extrude 4 has changed.

7. Click Complete Feature.

8. In the model tree, right-click Extrude 3 and select Edit:
   - Drag the lower sketched edge of the rectangle, so that the vertical length of the sketch increases from 7 to approximately 18.

Because the sketch in Extrude 4 is referenced to the edge of Extrude 3, its size changes as the size of Extrude 3 changes.
9. Click in the graphics area to complete the edit.

10. Spin the model so you can see how it has changed.

11. Erase the model from session:
   • Click **File > Manage Session > Erase Current**.
   • In the Erase Confirm dialog box, click **Yes**.

This completes the procedure.
Module 2

Basic Part Modeling

Module Overview
In this module, you will begin the creation of a wheel used in the Aston Martin slot car. The exercise will take you through the steps used to create the part model in Creo Parametric.

Objectives
After completing this module, you will be able to:
• Create new Creo Parametric parts.
• Understand basic sketcher theory and tools.
• Use sketcher to define an extruded shape.
• Create extrude features.
• Create hole features.
• Create datum planes.
Basic Part Modeling

The typical part model is created using four fundamental elements:

1. Default Datums
2. Base Feature
3. Extrude is a Sketched Feature
4. Hole is an Engineering Feature

New Part

Each new part you create in Creo Parametric will contain a default set of datum planes and a coordinate system that are copied in from a template model. Think of these default datums as the foundation that you build your part on.

Unlike solid geometry, reference geometry such as datum planes and coordinate systems have no mass, surface area, or size. Datum features are references used to sketch on, dimension to, assemble to, and so on. Their uses and benefits will become more apparent as you learn to use Creo Parametric.

Base Feature

The first solid feature you create is referred to as the “base” feature. It is typically an extrude or revolve feature placed at the center of the default
datum planes. After the base feature, additional features are added to further define the shape, size and function of your part. It is the combination of these features that will define the geometry of your part.

**Sketched Features**

Extrude and Revolve are the most commonly used “sketched” features. They are referred to as sketched features because the shape that is extruded or revolved is defined by a sketch. You will find sketched features in the Shapes group of the Model tab. Other, not so commonly used sketched features are sweeps, blends, and variable section sweeps.

**Engineering Features**

Engineering features are sometimes called “direct” or “pick & place” type features as they are applied directly to the model without the need for a sketch. Examples of Engineering type features are rounds, chamfers, holes, draft features, and so on. The shape of an Engineering type feature is defined by the feature type, dimension values, and references they are applied to. For example, a round feature is defined by the edge it is placed on and the radius value entered.
PROCEDURE - Basic Part Modeling

Scenario

You will begin modeling a wheel that will be used in the Aston Martin slot car. You will start by creating a new part that will initially contain only default datum features copied from the template model. You will then add simple features to define the basic shape and functional geometry of the wheel.

In subsequent exercises, you will document the wheel design in a drawing, create a wheel assembly that is assembled to the slot car and then, improve the wheel design by adding additional, more advanced features. Finally, you will create a photo realistic rendering of the completed design.

Step 1: Set your working directory and create a new part named wheel.

1. If necessary, start Creo Parametric 2.0.

2. From the Home tab, Data group, click Select Working Directory.

3. In the Select Working Directory dialog box:
   - Navigate to the folder Creo2_Adv_Primer.
   - Double-click the folder Module_02-06.
   - Double-click the folder Part.
   - Click OK to set the folder as your working directory.

   The wheel part you create will be saved to and opened from this "working directory".

4. Create the new wheel part model:
   - From the Quick Access toolbar, click New.
   - In the New dialog box, notice the default object Type is Part and Sub-type is Solid, these are the correct selections for creating a solid part.
   - In the Name field type wheel and click OK.
5. If necessary, from the In Graphics toolbar, click **Datum Display Filters** and disable the display of all datum features except datum planes.

The datum planes FRONT, RIGHT and TOP represent the 3-D space of your model. Think of these datums as the foundation your wheel will be built on.

**Step 2:** Start the Extrude tool and sketch a circle to define the shape of the wheel.

Begin the wheel design by starting the Extrude tool and sketching a 17.6 diameter circle on datum plane FRONT.

1. If necessary, press **CTRL + D** to reorient the model to its default orientation.
2. From the **Model** tab, **Shapes** group, click **Extrude**:
   - In the graphics area, select datum plane FRONT as your sketch plane.

Datum plane FRONT will be your sketch plane, think of it as the piece of paper you will be sketching on. Immediately after selecting it, the Sketch tab will open, presenting you with a variety of sketching tools.
3. From the In Graphics toolbar, click **Sketch View** to reorient the model to the 2-D sketch view.

You are now viewing the model in the 2-D sketch view orientation. The sketch plane FRONT is parallel to the screen, oriented by the datum plane named TOP facing the top of the screen.

4. In the **Sketching** group, select **Center and Point** from the Circle types drop-down menu:
   - Move your cursor over the blue horizontal and vertical reference lines. Notice the cursor snaps as you pass over the reference lines.
   - Click at **X1** to snap the center of the circle to the intersection of the reference lines.
   - Drag your mouse and click at **X2** to complete the circle. The actual size you sketch your circle is not important because it can be resized later.
   - Drag your mouse away from the circle and middle-click near **X3** to release the circle tool.
Light blue “weak” dimensions are automatically created when you sketch a shape. If you edited the dimension values, they will convert to dark blue “strong” dimension. Weak dimensions are Creo’s guess as to how the sketch should be dimensioned.

5. Edit the size of the circle:
   - Double-click the value of the weak diameter dimension (the numerical value at the end of the leader).
   - Edit the value to 17.6 and press ENTER.
   - When finished sketching, in the Close group, click OK.

When learning to sketch, it can be helpful to use the Undo and Redo buttons in the Quick Access toolbar. There is no need to cancel the sketch and start over.

Step 3: Define additional options to complete the extruded cylinder.

1. Press CTRL + D to reorient the model to its default orientation.

   The feature is automatically previewed using default extrude options. You will use the dashboard to edit those default options to create a solid cylinder that is extruded a depth of 4.5 mm, symmetrically about the sketch plane FRONT.
2. From the In Graphics toolbar, click **Datum Display Filters** and disable the display of all datum features.

3. From the dashboard located above the graphics area:
   - Click **Blind** and select **Symmetric** from the Depth types drop-down menu.
   - Edit the depth to **4.5** and press ENTER.
   - Click **Complete Feature**.

4. If necessary, from the In Graphics toolbar, click **Refit**.

**Step 4:** Use the Extrude tool to create a second solid cylinder.

- Use the Extrude tool to create a second solid cylinder that is extruded a depth of 9.2 mm, symmetrically about the sketch plane FRONT. A sketch of a 15.6 diameter circle will define the shape of the extrude.

1. If necessary, press CTRL + D.

2. From the **Model** tab, **Shapes** group, click **Extrude**:
   - In the model tree, select datum plane FRONT as your sketch plane.
Rather than reorienting the model into the 2-D sketch view, you will sketch this circle in the 3-D orientation.

3. Select **Center and Point** from the Circle types drop-down menu:
   • Click at X1 to snap the center of the circle to the intersection of the reference lines.
   • Drag your mouse and click at X2 to complete the circle.
   • Drag your mouse away from the circle and middle-click near X3 to release the circle tool.

4. Edit the size of the circle:
   • Double-click the value of the diameter dimension.
   • Edit the value to 15.6 and press ENTER.
   • When finished sketching, from the Close group, click **OK**.

Because the sketch plane FRONT is in the middle of the model, Creo Parametric has automatically edited this extrude to remove material.

5. From the dashboard:
   • Click **Remove Material** to disable it.
   • Click **Blind** and select **Symmetric** from the Depth types drop-down menu.
   • Edit the depth value to 9.2 and press ENTER.
   • Click **Complete Feature**.
Step 5: Use the Extrude tool to remove material from the part.

Use an Extrude to remove material from the wheel. The sketched circle will be offset .75 from the inner edge of the wheel. To meet our design requirements, the depth of the extrude will use a different depth type on each side of the sketch plane.

1. If necessary, press **CTRL + D**.

2. Click **Extrude**:  
   - From the model tree, select datum plane FRONT as the sketch plane.

3. From the In Graphics toolbar, click **Sketch View**.

4. Select **Center and Point** from the Circle types drop-down menu:  
   - Click at **X1** to snap the center of the circle to the intersection of the reference lines.  
   - Drag your mouse and click at **X2** to complete the circle.  
   - Middle-click to release the circle tool.

5. From the Dimension group, click **Normal**:  
   - Select the sketched circle at **X1**.  
   - Select the inner, circular model edge at **X2**.  
   - Middle-click at **X3** to place the dimension value.  
   - Type **.75** and press ENTER.

6. Click **OK**.
When creating a dimension, the first two selections are where the dimension’s arrowheads will attach, the middle-click is where the dimension’s value is placed.

7. From the In Graphics toolbar, click **Named Views** and select **Standard Orientation** from the drop-down menu.

8. On the left side of the dashboard, select the **Options** tab:
   - Edit the **Side 1** blind depth value to **1.5** and press ENTER.
   - From the **Side 2** drop-down menu, click **None** and select **Through All** from the drop-down menu.

The extrude will remove material a depth of 1.5 on Side 1 of the sketch plane and though the entire model on Side 2.

9. Spin the model so you can see how the material will be removed.
10. From the In Graphics toolbar, click **Named Views** and select **Right** from the drop-down menu.

To meet the wheel's design requirements, our engineers insisted the depth of this cut be a blind depth, 1.5 mm forward from datum plane FRONT and through the entire model in the other direction. This was done using both depth options **Blind** and **Through All**.

11. Complete the feature and save your work:
   - Press **CTRL + D**.
   - Click **Complete Feature**.
   - From the Quick Access toolbar, click **Save**:
     - Click **OK** to verify that the wheel will be saved in your working directory.

---

**Step 6:** Create a datum plane and use it as your sketch plane.

Create a datum plane that is offset 5 mm from the back of the wheel. You will use this new datum plane as the sketch plane for the next extrude feature. After completing the extrude feature, embed the datum plane into the extrude feature.

1. From the In Graphics toolbar, click **Datum Display Filters** and enable the display of datum planes.
2. Spin the model until you can view the back of the model.
3. From the **Model** tab, **Datum** group, click **Plane**.

4. From the selection filter in the lower-right of the interface, click **All** and select **Surface** from the Filter drop-down menu:
   - Select the back surface of the model, as shown in green. The datum plane will be offset from this surface.

5. In the Datum Plane dialog box:
   - Edit the Translation value to **5**. *You could also move the drag handle to offset the plane.*
   - Click **OK** to complete the feature.

6. With the new datum plane still selected, click **Extrude**.
   - **Because the new datum plane was selected before you clicked Extrude,** it was automatically used as the sketch plane.

7. Click **Center and Point**:
   - Sketch a circle at the center of the blue reference lines.
   - Middle-click to release the circle tool.
   - Edit the diameter to **4.25** and press ENTER.
   - Click **OK**.
8. Complete the feature definition:
   - In the graphics area, click the pink direction arrow so that the extrude direction is down, into the model.
   - Click **Blind** and select **To Next** from the Depth types drop-down menu.
   - Click **Complete Feature**.

   To help keep the model tree organized, embed datum plane DTM1 into Extrude 4.

9. In the model tree, embed datum plane DTM1 into **Extrude 4**:
   - Select and drag datum plane DTM1 onto **Extrude 4** and then release your mouse.
   - Expand **Extrude 4** and see that DTM1 is now embedded in the feature and also hidden.

10. From the In Graphics toolbar, click **Datum Display Filters** and disable the display of all datum features.
11. Edit the depth of **Extrude 4**:
   - In the model tree, right-click **Extrude 4** and then select **Edit** from the pop-up menu.
   - Edit the offset dimension 5 to 1 and press ENTER.
   - From the Quick Access toolbar, click **Regenerate** to update the model using the new offset value.

12. From the Quick Access toolbar, click **Save**.

Because DTM1 is embedded in Extrude 4, the offset dimension for DTM1 is now displayed when Extrude 4 is edited. To keep your model organized and easy to understand, it is best practice to embed datum features referenced by a specific feature.
Step 7: Create a coaxial type hole.

Use the Hole tool to create a coaxial hole on the axis of the axle hub. The hole will be 2.33 in diameter and have a blind depth of 6. The car axle will be inserted into the hole when assembled.

1. From the In Graphics toolbar, click **Datum Display Filters** and enable the datum axis display.
2. If necessary, spin the model until you can view the back of the model.

3. From the **Engineering** group, click **Hole**:  
   - In the graphics area, select axis **A_1** to position the hole.  
   - Press and hold **CTRL** and select the placement surface shown in green.  
   - Edit the hole diameter to **2.33** and depth to **6**.  
   - Click **Complete Feature**.

Because axis A_1 and the placement surface were selected as references, this hole was automatically created as a coaxial type hole. Other hole types available are Linear, Radial and Diameter.
4. From the In Graphics toolbar, click **Datum Display Filters** and disable the display of all datum features.

5. Check and then save your work:
   - Spin the model to view your design.
   - Press **CTRL + D**.
   - Click **Save**.

6. Erase the model from session:
   - Click **File > Manage Session > Erase Current**.
   - In the Erase Confirm dialog box, click **Yes**.

This completes the procedure.
Module 3

Basic Drawing Creation

Module Overview
In this module, you will begin the creation of a 2-D drawing documenting your wheel design. The exercise will take you through the basic steps used to create a 2-D drawing in Creo Parametric.

Objectives
After completing this module, you will be able to:
• Understand drawing concepts and theory.
• Create new drawings using drawing templates.
• Understand the drawing ribbon user interface.
• Edit the drawing scale.
• Edit the properties of drawing views.
• Create a cross-section view.
• Show and manipulate annotations in your drawing views.
• Save your drawing as a PDF file.
Basic Drawing Creation

Drawing creation can be summarized in four basic steps:

1. Create a New Drawing
2. Add and Manipulate Views
3. Show and Create Annotations
4. Manipulate Annotations

Drawings Theory

Part and assembly designs are typically documented in a 2-D drawing. While not always required, the 2-D drawing is the traditional final design deliverable at many companies. The released 2-D drawing in conjunction with the 3-D model geometry is then used to create and inspect the completed design.

A 2-D drawing contains parametric views of the 3-D design model, dimensions, and a title block. The drawing may also contain notes, tables, and further design information.

A Creo Parametric drawing is bi-directional. If a change is made to the design model, the drawing that displays that model automatically updates to reflect the change. Conversely, if a change is made in the drawing, the design model automatically updates accordingly.

Creating a New Drawing

There are three methods for creating a drawing:

- **Use template** - A template drawing is used to automatically create a drawing containing predefined views, format, and possibly annotations.
- **Empty with format** - A drawing is created based on a selected format size. All views of the design model must be added manually.
• **Empty** - A drawing is created based on a selected drawing size. The views and format must be added manually.

In this exercise we will create a drawing using a template. A template does not give you a perfectly completed drawing but it does give you a head start by automatically placing views and the drawing format.

### Add and Manipulate Views

Even when a drawing is created using a template, additional views are typically required to properly document a design. The following view types can be added to a drawing:

- General - You define the orientation of this view.
- Projection - This view is automatically projected from an existing view.
- Detailed - A detailed close up view of a selected area on another view.
- Auxiliary - A view projected from selected geometry of an existing view.
- Revolved - A revolved section view.

Each view has a set of properties that can be edited to change the view type, display, scale, and other options.

### Show and Create Annotations

You can show the dimensions and notes that are in your part or assembly, in your drawing. This means you are not required to recreate dimensions to document your design.

If required, you can also create “driven” dimensions in a drawing. Unlike dimensions shown from the model, driven dimensions will not drive your model design. Driven dimensions will update when your model changes.

Notes and datum annotations can also be shown or created in a drawing.

### Manipulate Annotations

Drawing annotations can be manipulated to create a clean and standard compliant drawing. Annotations can be moved, tolerances added, text size changed, and so on. Anything needed to create a standard compliant drawing is possible in Creo Parametric.
PROCEDURE - Basic Drawing Creation

Scenario

Complete this module to learn how to document your design in a 2-D drawing. If drawing creation and drafting principles are not taught in your program, skip to Module 4.

Now that you have started the design of the wheel, you will begin documenting the design in a 2-D drawing. After you create a new drawing using a template, you will edit properties of the drawing views. You will then show and manipulate dimensions in the drawing.

In subsequent exercises, you will create a wheel assembly that is assembled to the slot car and then, improve the wheel design by adding advanced features. Finally, you will create a photo realistic rendering of the final design.

Step 1: Begin documenting the wheel design in a 2-D drawing.

Beginning the documentation of your design before it is complete, promotes concurrent design and provides an additional tool for assessing your design early in the process.

In this step, create a drawing using the A3 size drawing template.

1. If necessary, start Creo Parametric 2.0.
2. From the Home tab, Data group, click Select Working Directory.
3. In the Select Working Directory dialog box:
   • Navigate to the folder Creo2_Adv_Primer.
   • Double-click the folder Module_02-06.
   • Double-click the folder Drawing.
   • Click OK to set the folder as your working directory.

The drawing you create will be saved to and opened from this “working directory”.

4. From the Quick Access toolbar, click New.
5. In the New dialog box:
   • Select Drawing as the Type.
   • Type wheel in the Name field and click OK.
6. From the New Drawing dialog box:
   - If the Default Model has not already been set to WHEEL.PRT, click **Browse**, select WHEEL.PRT and click **Open** to set the drawing's default model.
   - From the Template list, select **a3_drawing**.
   - Click **OK** and a drawing will automatically be created.

7. If necessary, from the In Graphics toolbar:
   - Click **Datum Display Filters** and disable the display of all datum features.
   - Click **Repaint** to update the display.

An A3 drawing is 297 X 420 mm, similar in size to an ANSI B size which is 11 X 17 inches.
8. Browse through some of the drawing tabs to observe the functionality found in each:

- **Layout** – Sheets, formats, views, display settings and drawing objects are controlled from this tab.
- **Table** – Tables are created and edited using tools in this tab.
- **Annotate** – Dimensions, notes and tolerances are shown, created and controlled using tools in this tab.
- **Sketch** – 2-D draft entities can be sketched using tools in this tab.
- **Legacy Migration** – Tools used for importing and working with drawings created in other systems are found in this tab.
- **Analysis** – Tools for measuring and analyzing drawing entities and models are found in this tab.
- **Review** – Update your drawing, compare different versions, query for information and take measurements using tools in this tab.
- **Tools** – Miscellaneous tools for investigation, adding model intent, along with various utilities and applications are found in this tab.
- **View** – View controls for the drawing such as layers, orientation and model display are found in this tab.
9. If necessary, select the **Layout** tab.

10. Edit the overall drawing scale:
   - Double-click the text **SCALE: 3:1** located in the lower-left of the graphics area.
   - Enter 4 and press ENTER to change the overall drawing scale.

11. Zoom in on the 3-D shaded view:
   - Press and hold **CTRL**, then middle-click and drag over the shaded view. Drag your mouse toward you to zoom-in, away from you to zoom-out.
   - Release the **CTRL** key, then middle-click and drag to position the view in the center of the graphics area.

   You can also cursor over and then scroll the middle-mouse wheel to zoom in and out from a drawing view or entity.

**Step 2:** Edit the display properties of individual drawing views.

1. Edit properties of the shaded view:
   - Press the **ALT** key and move your cursor over the shaded view; when the view highlights, select it.
   - Right-click and select **Properties** from the pop-up menu.

2. In the Drawing View dialog box, edit the scale of the view:
   - In the **Categories** list, click **Scale**.
   - Select **Custom scale**, edit the value to 2 and press ENTER.
   - Click **Apply** and observe that the view is scaled and a scale note automatically added.

3. In the Drawing View dialog box, edit the display of the view:
   - In the **Categories** list, click **View Display**.
   - Select **Shading With Edges** from the Display style drop-down menu.
   - Click **OK** to apply the change and close the dialog box.
4. To select a note or dimension, with the Layout tab open, press the ALT key while selecting. Alternatively, you can open the Annotate tab and then select annotations without using ALT:
   - Click in an empty area of the graphics area to deselect the view.
   - Press ALT and then select the view note SCALE 2:1, a green selection box will display around the note.

The ALT key works as a filter enabling you to select various drawing entities no matter which tab is open. The drawing tabs work as filters, without pressing ALT, annotations cannot be selected when the Layout tab is open and view properties cannot be edited when the Annotate tab is selected. A good rule of thumb is when in doubt, press the ALT key to select an entity.

5. With the view note selected, right-click and select Edit Value from the pop-up menu:
   - Edit the scale from 2 to 3 and press ENTER.
   - Drag the note so that it is centered under the view.

6. From the In Graphics toolbar, click Refit.

7. Ensure that the Layout tab is still open.

8. Click in an empty area of the drawing to deselect the note.

9. Move your cursor over the top view, when the view highlights, click to select it.

10. Right-click and select Properties:
    - In the Categories list, click View Display.
    - Select Hidden from the Display style drop-down menu.
    - Click OK.
11. If necessary, from the In Graphics toolbar, click Refit.
12. Move your cursor over the right view, when the view highlights, click to select it.
13. Right-click and select Properties:
   • In the Categories list, click Sections.
   • From the Section options area, select 2D cross-sections.
   • Click Add Section and then Done from the menu manager in the lower-right.
   • Type A as the cross-section name and press ENTER.
   • Select datum plane RIGHT from the model tree.
   • Click OK.
14. With the right view still selected, right-click and select Add Arrows, then click the front view to place the cut arrows.
Step 3: Show the model’s dimensions and axis in the drawing.

1. If necessary, click Refit and click in an empty area of the drawing to deselect the section view A-A.
2. In the ribbon, select the Annotate tab and click Show Model Annotations.
3. In the model tree, select Extrude 1, then press and hold SHIFT while you select Hole 1.
4. In the Show Model Annotations dialog box:
   • Click Select All to show all dimension from the selected features.
   • Select the Datums Tab and in the Show column:
     – Click Select All to enable the display of axis A_1 in each views.
     – Disable the check-box that controls the display of the axis in the 3-D shaded view.
   • Click OK.
5. Right-click in the graphics area and select Cleanup Dimensions:
   • Disable Create Snap Lines.
   • Edit the Offset value from 12.5 to 8 and press ENTER.
   • Click Apply and then click Close.
6. Click in the graphics area to deselect the dimensions.
7. Click Repaint.
Step 4: Manipulate drawing annotations.

1. If necessary, click **Refit**.
2. With the **Annotate** tab open, press ALT and select any dimension, axis, or note you want to manipulate. Multiple items can be selected using the CTRL key or pick-box selection.
3. Use the following methods to manipulate the selected annotations:
   - To move the dimension and text, or a note, click and drag the handle at the center of the text.
   - To move only the dimension’s text, click and drag the handles at either side of the text.
   - To move the entire dimension, click and drag handles at the arrow head tips.
   - To clip the dimension witness lines, click and drag the handle at the end of each extension line.
   - To flip dimension arrows, right-click and select **Flip Arrows**.
   - To resize an axis, drag the handle at either end of the selected axis.
   - To move a dimension from one view to another, right-click and select **Move Item to View**, then click the view you want the item moved to.
4. To move a view, select the view you want to move, then right-click and deselect the **Lock View Movement**, then drag the view to a new location.
Step 5: Add model parameters in the drawing format and print the drawing.

1. Pan to and then zoom in on the title block area of the drawing, located in the lower-right corner of the drawing.

   ![Title block image]

   No Title or Project names are displayed. The parametric format used in the drawing reads this information from the model and that information has not been entered yet.

2. In the model tree, right-click WHEEL.PRT and select Open.

3. From the Tools tab, Model Intent group, click Parameters.

4. In the Parameters dialog box:
   - Edit the Value of the DESCRIPTION parameter to PTC ASTON MARTIN WHEEL DESIGN.
   - Edit the Value of the PROJECT parameter to PTC SLOT CAR.
   - Click OK.

5. From the Quick Access toolbar, click Windows and select WHEEL.DRW to activate the drawing.

   The parametric format read the parameters from the model!

![Drawing with parametric information]

Module 3 | Page 12 © 2009 PTC
6. Click **Refit**.

7. Click **File > Save As > Quick Export** to create a PDF of the drawing.

8. Save the drawing and then close the open windows from the Quick Access toolbar:
   - Click **Save** and click **OK** to verify that the drawing will be saved in your working directory.
   - Click **Close Window** to close the WHEEL.DRW window.
   - Click **Close Window** to close the WHEEL.PRT window.

9. Erase all open files from session:
   - From the **Home** tab, **Data** group, click **Erase Not Displayed**: 
     - In the Erase Not Displayed dialog box, click **OK**.

This completes the procedure.
Module 4

Basic Assembly Modeling

Module Overview

In this module, you will create a wheel assembly, containing the wheel part you have started to design along with an already complete tire part.

After you have completed the wheel subassembly, you will add it to the front and rear axle assemblies. The exercise will take you through the basic assembly steps. After placing the wheel assembly into the front axle assembly the first time, you will use copy and paste to save time placing three additional instances of the subassembly.

Objectives

After completing this module, you will be able to:

• Create new Creo Parametric assembly.
• Assemble the first component of an assembly using the Default constraint.
• Use the 3-D Dragger to orient a component being assembled.
• Assemble components using the Automatic option to create Coincident constraints.
• Use copy and paste functionality to assemble components.
Basic Assembly Modeling

The basic assembly modeling process can be summarized in four steps:

1. Default Assembly Datums
2. Placement of First Component
3. Orient Added Components
4. Constrain Components

New Assembly

Each new assembly you create in Creo Parametric will contain a default set of datum planes and a coordinate system, copied in from a template model. Think of these default datums as the foundation that you begin assembling components to.

Unlike solid geometry, reference geometry such as datum planes and coordinate systems have no mass, surface area, or size. Assembly datum features are often used as assembly references.

Default Placement of the First Component

To place the first component in your assembly, click Assemble from the Component group of the Model tab. In the Open dialog box, select the component you want to assemble and click Open, then click to position the model anywhere in the graphics area.

Unless you require a specific orientation, the first component of an assembly is typically placed using the Default Constraint. Apply the Default Constraint using one of the following methods:

- Right-click in the graphics area and select Default Constraint from the pop-up menu.
• In the assembly dashboard at the top of the graphics area, click **Automatic** and select **Default** from the drop-down menu.

If necessary, constraints such as **Coincident**, **Parallel** and **Distance** can also be used to position the first component of your assembly.

### Orient Added Components

Additional components are placed in the assembly using the **Assemble** tool. As subsequent components are added to the assembly, it is often helpful to reorient the component inside the assembly, before constraints are applied.

As with any model in Creo Parametric, if you middle-click and drag, the entire assembly will spin. To reorient only the component being assembled, use the 3-D Dragger or one of the following keyboard and mouse combinations:

**3-D Dragger** – The color coded 3-D dragger is used to orient the component being assembled within the assembly. As constraints are added and the degrees of freedom are reduced, you will notice that those corresponding portions of the dragger are grayed out.

• The shaded arcs of the dragger control rotation about the three axes.
• The shaded arrows translate the component along those axes.
• These small translucent quadrants move the component in a 2-D plane.
• The small sphere at the center is used to pan the component in any direction.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Spin</strong> – The component will spin within the assembly. Partially constrained components only spin in unconstrained directions.</td>
<td>Ctrl + Alt +</td>
</tr>
<tr>
<td><strong>Pan</strong> - The component will pan about the assembly. Partially constrained components only pan in unconstrained directions.</td>
<td>Ctrl + Alt +</td>
</tr>
<tr>
<td><strong>Component Drag</strong> – The component will spin and pan about the assembly. Partially constrained components can only be dragged in unconstrained directions.</td>
<td>Ctrl + Alt +</td>
</tr>
</tbody>
</table>
Constrain Components

After you have placed and oriented a component it is important that you add assembly constraints to define its final design position. Using the wheel and tire assembly shown:

- A **Coincident** constraint is applied to cylindrical surface of each part. This constraint type makes the center axis of each model coincident.
- A second **Coincident** constraint is applied to datum planes FRONT of each model. Making the two planes coincident, centers the tire on the wheel.
- There is actually one degree of freedom remaining, the wheel can still spin about the center axis of the wheel. An additional constraint could be added but by default, Creo Parametric assumes it is fully constrained. This is done to save time because often, the remaining degree of freedom is not required to position a component with coincident axes.

Constraints such as **Coincident**, **Parallel**, **Distance** and so on can be explicitly selected from the constraint drop-down menu in the dashboard under **Automatic**, however, it is often easier to let Creo Parametric select them based on the references you select. In this case, selecting the two cylindrical surfaces caused a **Coincident** constraint to be automatically applied. If the planes were farther apart when selected, a **Distance** constraint may have been applied.
PROCEDURE - Basic Assembly Modeling

Scenario
You will start by creating a new assembly model into which you will assemble your wheel and then an existing tire model. After the wheel assembly is complete you will assemble it to the front and rear axle assemblies.

To save time, after assembling the wheel subassembly the first time, you will use Copy and Paste to assemble the remaining three instances. Finally, you will open the Aston Martin assembly to see how the new wheels look on the car.

In subsequent exercises, you will improve the wheel design by adding additional, more advanced features and then finally, you will create a photo realistic rendering of the completed design.

Step 1: Create an assembly containing WHEEL.PRT and TIRE.PRT.

1. If necessary, start Creo Parametric 2.0.

2. From the Home tab, Data group, click Select Working Directory.

3. In the Select Working Directory dialog box:
   - Navigate to the folder Creo2_Adv_Primer.
   - Double-click the folder Module_02-06.
   - Double-click the folder Assembly.
   - Click OK to set the folder as your working directory.

   The assembly you create will be saved to and opened from this "working directory".

4. Create the new wheel part model:
   - From the Quick Access toolbar, click New.
   - Select Assembly as the Type.
   - Type wheel in the Name field and click OK.
Assemble the wheel using a Default Constraint, then assemble the tire to the wheel using Automatic to create Coincident constraints that will position the tire onto the wheel.

5. If necessary, from the In Graphics toolbar, click **Datum Display Filters** and disable the display of all datum features.

6. From the **Model** tab, **Component** group, click **Assemble**.

7. In the Open dialog box, select WHEEL.PRT and click **Open**:  
   - Click in the graphics area to position the part.  
   - In the graphics area, right-click and select **Default Constraint** from the pop-up menu.  
   - Click **Complete Component**.

Unless you require a specific orientation, the first component of an assembly is typically placed using the **Default Constraint**.

8. Click **Assemble** from the **Component** group.

9. In the Open dialog box, select TIRE.PRT and click **Open**:  
   - Click in the graphics area to position the tire near the wheel.
10. Select the first set of constraint references:
   • Select the inner cylindrical surface of TIRE.PRT.
   • Select the outer cylindrical surface of WHEEL.PRT.

   Notice in the dashboard that a **Coincident** type constraint was created.

11. From the In Graphics toolbar, click **Datum Display Filters** and enable the display of datum planes.

12. Select the second set of constraint references:
   • Move your cursor over datum plane FRONT in TIRE.PRT and when it highlights, select it.
   • Move your cursor over datum plane FRONT in WHEEL.PRT and when it highlights, select it.

13. Ensure that the Constraint type shown in the dashboard is **Coincident** and not **Distance**.

   If you select the wrong reference when assembling components, you can use the **Undo** button to backup and re-select. There is no need to cancel the component placement and start over.
14. On the left side of the dashboard, select the Placement tab:
   • Notice that a constraint set containing two Coincident type constraints was created based on the references you selected.
15. Click Complete Component.
16. Click Datum Display Filters and disable the display of datum planes.
17. Spin the assembly and observe the assembled components.
18. Press CTRL + D to reorient the model.
19. From the Quick Access toolbar, click Save:
   • Click OK to verify that the model will be saved in your working directory.

Step 2: Assemble the WHEEL.ASM to AXLE_FRONT.ASM.

You will now assemble your wheel assembly to both the front and rear axle assemblies.

1. From the Quick Access toolbar, click Open:
   • Select AXLE_FRONT.ASM and click Open.
2. From the Component group, click Assemble:
   • Select WHEEL.ASM and click Open.

If you do not see the WHEEL.ASM model listed in the Open dialog box, this means you forgot to save it in the step above. To select the unsaved model from session, click In Session from the Common Folders list in the Open dialog box.
3. Click in the graphics area to position the WHEEL.ASM.

4. Use the **3-D Dragger** to reorient the wheel assembly:
   - Drag the green shaded ring to rotate WHEEL.ASM so that you can see the back of the wheel.

5. Select the first set of constraint references:
   - Select the cylindrical surface of AXLE.PRT.
   - Select the cylindrical surface of the hole in WHEEL.PRT.

6. Flip the orientation of the wheel:
   - Right-click in the graphics area and select **Flip Constraint** from the pop-up menu.
7. Drag the WHEEL.ASM away from the axle:
   - Spin the assembly so that you can see the back of the WHEEL.ASM.
   - Drag the blue arrow on the 3-D Dragger to move WHEEL.ASM away from axle.
   - Spin the assembly until you can see the bottom of the hole in WHEEL.PRT.

8. Select the second set of constraint references:
   - Select the circular surface at the bottom of the hole in WHEEL.PRT.
   - Spin the assembly until you can see the end surface of AXLE.PRT:
     - Select the circular surface at the end of AXLE.PRT.

9. Ensure that the constraint type shown in the dashboard is **Coincident** and not **Distance**.

   The end of the axle should now be coincident to the bottom of the hole.
   Rather than spinning the model to select the circular surface of the axle, you could have used your Query Select skills (discussed in Module 1) to select it. If you want to try, click **Undo** and try again, without spinning the model.
10. Press **CTRL + D**.

11. Click **Complete Component ✔**.

Next you will use copy and paste to assemble the second **WHEEL.ASM**.

12. In the model tree, select **WHEEL.ASM**:
   - Press **CTRL + C** to copy.
   - Press **CTRL + V** to paste.

13. Click in the graphics area to position **WHEEL.ASM**:
   - Spin the assembly until you can see the end surface of **AXLE.PRT**.

Creo Parametric remembers the references selected in **WHEEL.ASM** the first time you assemble it. The second time, you will only have to select references from **AXLE.PRT**.

14. Define constraint references from **AXLE.PRT**:
   - Select the cylindrical surface of **AXLE.PRT** as the first **Coincident** reference.
   - If necessary, use the **3-D Dragger** to move **WHEEL.ASM** away from **AXLE.PRT**.
   - Select the circular end surface of **AXLE.PRT** as the second **Coincident** reference.

15. Right-click and select **Flip Constraint**.
16. Click **Complete Component**.
17. Press **CTRL + D**.
18. From the Quick Access toolbar, click **Save**.

**Step 3:** Assemble the WHEEL.ASM to AXLE_REAR.ASM.

Copy WHEEL.ASM into the AXLE_REAR.ASM.

1. Click **Open** and double-click AXLE_REAR.ASM.
2. Paste WHEEL.ASM into the AXLE_REAR.ASM:
   • Press **CTRL + V** to paste.
   • Click in the graphics area to position WHEEL.ASM.

If your WHEEL.ASM is pasted into the graphics area with the back of the wheel facing you, this is because you copied the second instance of WHEEL.ASM from AXLE_FRONT.ASM, rather than the first. You can either work your way through it or go back to the AXLE_FRONT.ASM and copy the first WHEEL.ASM.
3. Select the cylindrical surface of AXLE.PRT as the first **Coincident** reference.

4. Select the second **Coincident** reference from AXLE.PRT:
   - If necessary, use the **3-D Dragger** to move WHEEL.ASM.
   - Select the circular end surface of AXLE.PRT.

5. Click **Complete Component** ✔.
6. Spin the assembly and observe the assembled components.
7. Press **CTRL + D**.
8. Paste the second WHEEL.ASM into the assembly:
   - Press CTRL + V to paste.
   - Click in the graphics area to position WHEEL.ASM.
   - Spin until you can see the end surface of AXLE.PRT.

9. Select the cylindrical surface of AXLE.PRT as the first **Coincident** reference.

10. Select the second **Coincident** reference from AXLE.PRT:
    - If necessary, use the **3-D Dragger** to move WHEEL.ASM.
    - Select the circular end surface of AXLE.PRT.

11. Right-click and select **Flip Constraint**.

12. Click **Complete Component**.

13. Spin the assembly and observe the assembled components.

14. Press CTRL + D.

15. Click **Save**.
Step 4: Open the Aston Martin assembly to see how the new wheels look.

1. Click Open:
   • Select ASTON_MARTIN.ASM and click Open.

   Your new wheels look a little dull on such a hot car, don’t you think? In the next module, you will add some details to make it look much better.

2. Close the windows and erase open files from session:
   • Click Close Window a few times until you have closed all the open Creo Parametric windows.
   • From the Home tab, Data group, click Erase Not Displayed:
     – In the Erase Not Displayed dialog box, click OK.

This completes the procedure.
Module Overview

In this module, you will complete the wheel design by adding additional features and then by making edits based on your evaluation of the design. You will first add additional features to make the wheel more esthetically pleasing. Next, you will cut a cross-section through the wheel assembly and take measurement to evaluate its fit to the tire. Finally you will make edits to the design and observe that changes made in one mode are automatically updated in every other mode of Creo Parametric. For example, a change made in the drawing is automatically propagated to the part and assembly models.

Objectives

After completing this module, you will be able to:

• Create a revolve feature.
• Use geometry tools within sketcher.
• Mirror sketcher geometry.
• Create an axial pattern.
• Create an extrude with taper.
• Create a multi-set round feature.
• Create an reference patterns.
• Create an chamfer feature.
• Apply real time rendering to your model.
• Cut and display a cross-section.
• Use measure tools to evaluate your models.
Advanced Modeling and Design

To complete the wheel design, you will use a variety of advanced features and design tools.

Advanced Features
- Revolve
- Round
- Extrude with Taper
- Chamfer

Patterns
- Axis Pattern
- Reference Pattern

Cross-Sections

Measuring Tools

Bi-directional Associativity

Advanced Features
To complete the wheel design, you will use some features you have not yet tried.

- Revolve - A sketched feature in which the sketch is revolved about a centerline or axis in order to add or remove material.
- Extrude with Taper - Used to apply slope to the side walls of an extrude feature. Typically used to enable mold or cast parts to be removed from the tool they are created in.
- Round - Add or remove material by creating smooth, usually radial transitions on an edge or between surfaces.
- Chamfer - Add or remove material by creating a beveled surface on an edge or between surfaces.
Patterns
The Pattern tool enables you to quickly duplicate a feature within your model. In this exercise, you will learn to pattern about an axis using the Axis type pattern. You will also use the Reference pattern to create patterns where a feature follows the pattern of a feature it references.

Cross-Sections
You will cut a cross-section through the wheel assembly so that you can visually inspect the fit of the tire to the wheel. The display of cross-sections can be toggled on and off in the part, assembly or drawing.

Measuring Tools
You will use Creo Parametric's measuring tools to analyze the size and fit of your models. Values obtained from the measuring tools are used to edit the wheel so that it fits the tire correctly.

Bi-directional Associativity
You will make edits to your design in both the part and drawing modes. You will then observe that because of bi-directional associativity, a change made anywhere is updated everywhere.
PROCEDURE - Advanced Modeling and Design

Scenario

The marketing group called and they said your wheel is too plain to be put on their Aston Martin slot car. They have a point, it’s ugly!

In this exercise you will add additional features to improve on the look and feel of the design. You will cut a cross-section through the wheel assembly so that you can verify the fit and function of the design both visually and using the measurement tools. Based on measurements taken, you will edit your design so that it not only looks better but functions better.

In the subsequent exercise, you will create a photo realistic rendering of the completed design.

Step 1: Open the Aston Martin assembly.

1. If necessary, start Creo Parametric 2.0.

2. From the Home tab, Data group, click Select Working Directory.

3. In the Select Working Directory dialog box:
   - Navigate to the folder Creo2_Adv_Primer.
   - Double-click the folder Module_02-06.
   - Double-click the folder Advanced.
   - Click OK to set the folder as your working directory.

4. From the Quick Access toolbar, click Open:
   - In the File Open dialog box, double-click ASTON_MARTIN.ASM.

5. If necessary, from the In Graphics toolbar, click Datum Display Filters and disable the display of all datum features.
Step 2: Remove material using the Revolve tool.

Open the wheel and use a revolve feature to add some detail to your design.

1. In the graphics area, select any one of the WHEEL.PRT parts from ASTON_MARTIN.ASM:
   • With WHEEL.PRT selected, right-click and select Open from the pop-up menu.

2. From the Model tab, Shapes group, click Revolve.

3. Select and orient the sketch plane:
   • From the model tree, select datum plane TOP as the sketch plane.
   • From the In Graphics toolbar, click Sketch View to reorient the model to the 2-D sketch view.
   • In the graphics area, right-click and select Section Orientation > Flip section orientation.

4. From the In Graphics toolbar, click Datum Display Filters and enable the display of datum axes.

5. From the In Graphics toolbar, select Hidden Line from the Display Style types drop-down menu.
6. From the In Graphics toolbar, click Zoom In
   • Click at X1 to define the upper-left corner of the zoom box.
   • Click at X2 to define the lower-right corner of the zoom box.
   • Middle-click to release the zoom in tool.

7. From the Sketching group, select Centerline from the Centerline types drop-down menu:
   • Click at X1 to start the centerline.
   • Click at X2 to make the centerline horizontal.
   • Middle-click to release the centerline tool.
8. From the **Sketching** group, select **3-Point / Tangent End** from the Arc types drop-down menu:
   - Click on the vertical reference, below the centerline at \( X_1 \) to place the start point of the arc.
   - Click on the centerline at \( X_2 \) to place the endpoint of the arc.
   - Move your cursor to size the arc, then click near \( X_3 \) to complete the arc.
   - Middle-click to release the arc tool.

   ![Diagram of arc creation process](image)

   Use a tangent constraint to make the arc tangent to the horizontal centerline. If you see a \( T \) (tangent constraint symbol) at the end of the arc, it is already tangent and you can skip this task.

9. From the **Constrain** group, click **Tangent**:
   - Select the arc and then select the horizontal centerline.
   Notice a \( T \) is now displayed at the end of the arc, signifying it is tangent to the horizontal centerline.

   ![Diagram of tangent constraint](image)

   **Tip**: Do not forget, you can use **Undo** and **Redo** if you make a mistake while learning to use sketcher.
10. From the **Dimension** group, click **Normal**:  
   - Select the top edge of the wheel at **X1**.  
   - Select the centerline at **X2**.  
   - Middle-click at **X3** to place the dimension.  
   - Edit the value of the dimension to **.5** and press ENTER.

11. Double-click the radius dimension’s value, edit it to **25** and press ENTER.

The radius dimension is a weak dimension that was automatically created, you may have to zoom out to see it.

12. In the **Sketching** group, select **Line Chain** from the Line types drop-down menu:  
   - Snap the start point of the line to the endpoint of the arc, shown at **X1**.  
   - Snap the endpoint to the blue reference line at the top of the wheel, shown at **X2**.  
   - Middle-click to release the line tool.

Sketch a line that is at approximately a 45 degree angle, from the endpoint of the arc to the top edge of the wheel.
The blue reference line at the top of the wheel was created when that edge was selected to create a dimension. If it was not there, you could have added it while sketching the line by pressing ALT and selecting the edge.

Use Normal to create horizontal dimensions that define the location of the upper and lower endpoints of the line.

13. From the Dimension group, click Normal:
   - Select the vertical edge shown at X1.
   - Select the upper endpoint of the line, shown at X2.
   - Middle-click at X3 to place the dimension.
   - Edit the value of the dimension to .3 and press ENTER.

14. Click Normal:
   - Select the vertical edge shown at X1.
   - Select the lower endpoint of the line, shown at X2.
   - Middle-click at X3 to place the dimension.
   - Edit the value of the dimension to .5 and press ENTER.

15. From the Close group, click OK.
16. Press **CTRL + D** to reorient the model.

17. From the In Graphics toolbar, select **Shading With Edges** from the Display Style types drop-down menu.

18. In the graphics area:
   - Select datum axis **A_1** as the **Axis of Revolution**.
   - Right-click and select **Remove Material** from the pop-up menu.
   - If necessary, click the pink material side arrow so that it is pointing away from the model.

19. Click **Complete Feature**.

20. Click **Datum Display Filters** and disable the display of all datum features.

21. Check and then save your work:
   - Spin the model to view your design.
   - Press **CTRL + D** to reorient the part.
   - Click **Save**.
Step 3: Extrude and pattern spokes in the wheel.

Use an extrude feature to remove material in the shape of a spoke.

1. Click Extrude and in the model tree, select datum plane FRONT.

2. From the In Graphics toolbar, click Sketch View to reorient the model to the 2-D sketch view.

3. From the Sketching group, click Project:
   - Move your cursor just below the inner edge of the revolve feature and select the hidden edge highlighted in green.
   You are selecting an edge of Extrude 3 on the other side of the model, labeled as Edge:F7(EXTRUDE_3).

4. In the Sketching group, select Centerline from the Centerline types drop-down menu:
   - Click at X1 to snap the start point to the vertical reference.
   - Click at X2 to make the centerline vertical.
   - Middle-click to release the centerline tool.

5. Select Center and Point from the Circle types drop-down menu:
   - Click at X1 to snap the center of the circle to the center of the model.
   - Drag your cursor and click at X2 to complete the circle.
   - Middle-click to release the circle tool.

6. Edit the diameter to 5 and press ENTER.
7. Select **Line Chain** from the Line types drop-down menu:
   - Click at X1 to snap the start point of the line to the center of the model.
   - Click at X2 to snap the endpoint of the line to the upper arc.
   - Middle-click to release the line tool.

8. With the newly sketched line still selected:
   - From the **Editing** group, click **Mirror**.
   - Select the vertical centerline as the reference to mirror about.

Delete extra sketcher geometry, leaving only the two sketched lines and arcs to be extruded.

9. From the **Editing** group, click **Delete Segment**:
   - In the graphics area, select each line and arc identified by an X. After the extra entities are deleted, the sketch will be a closed loop.
10. Middle-click to release the delete segment tool:
   • If your sketch is shaded, you have a single closed loop that can be extruded as a solid.
   • If it is not shaded, your sketch has either open ends or overlapping entities that must be removed.

   ![Sketch Diagram]

   The most common issue users have with this sketch is not deleting all of the extra lines and arcs. In the Inspect group, you will find tools for finding open and overlapping sketch entities. Zoom out and use these tools to find any extra or overlapping entities.

11. From the Dimension group, click Normal:
   • Select each angled line, X1 and X2.
   • Middle-click between the lines at X3 to place the dimension.
   • Edit the angle dimension value to 25 and press ENTER.

12. From the Close group, click OK.
13. Press CTRL + D.
14. In the graphics area:
   • Right-click and select Remove Material from the pop-up menu.
   • Right-click on the depth drag handle (small white box) and select Through All from the pop-up menu.
15. Click Complete Feature.
As you can see from the steps above, many of the options you have been selecting in the dashboard are also accessible using right–click pop-up menus in the graphics area.

16. Click Datum Display Filters \( \text{Datum Display Filters} \) and enable the display of datum axes.

Use an Axis type pattern to evenly space duplicates of Extrude 5 about the center axis of the wheel.

17. With Extrude 5 still selected:
   • From the Editing group, click Pattern \( \text{Pattern} \)

18. From the dashboard:
   • Click Dimension and select Axis from the Pattern types drop-down menu.
   • Select axis A_1 from the model.
   • Edit the number of pattern instances from 4 to 6.
   • Click Equal Spacing \( \text{Equal Spacing} \) to evenly space the distance between the 6 instances.
   • Click Complete Feature \( \text{Complete Feature} \).

19. Click Datum Display Filters \( \text{Datum Display Filters} \) and disable the display of datum axes.

20. Check and then save your work:
   • Spin the model to view your design.
   • Press CTRL + D.
   • Click Save \( \text{Save} \).
Step 4: Use an extrude feature to add a tapered hub to the front-center of the wheel.

1. Click Extrude: 
   - Select the thin circular surface at the front of the wheel as your sketch plane.

2. Select Center and Point from the Circle types drop-down menu:
   - Sketch a circle at the center of the blue reference lines.
   - Middle-click to release the circle tool.
   - Edit the circle’s diameter to 2 and press ENTER.
   - Click OK.

3. Define the hub’s direction and add taper:
   - Click the pink direction arrow to flip the extrude direction back into the model.
   - Right-click and enable Add Taper from the pop-up menu.
   - Drag the taper drag handle (small white box) and expand the taper to 30 degrees.

💡 You can also enable and edit taper from the Options tab in the dashboard. Taper can also be added to your model as a separate feature, using the Draft tool.
4. Define the hub’s depth:
   - Right-click the depth drag handle and select To Next.

5. Complete the feature and save your work:
   - Click Complete Feature.
   - Press CTRL + D.
   - Spin the model to view your design.
   - Click Save.

Attributes of a feature such as direction, depth and taper can also be defined using the buttons, pull-down menus and tabs in the dashboard. Experienced users typically use a combination of commands from both the dashboard and pop-up menus.

Step 5: Round the edges of the wheel spokes.

Add a round to the first instance of the Extrude 5 so that it can be patterned to all the spokes.

1. In the model tree, expand Pattern 1 of Extrude 5:
   - Select Extrude 5[1] to identify the first instance of the pattern. This is where you will place the round feature.
   - Spin the model until you can see the upper surface of this feature.

2. From the Engineering group, click Round from the Round types drop-down menu:
   - Select the edge shown as X1.
   - Press and hold CTRL while you select the edge shown as X2.
   - Edit the radius to .75 and press ENTER.
3. Press **CTRL + D**.

4. Add a second set of edges to the round:
   - Select the edge shown as **X1**.
   - Press and hold **CTRL** while you select the edge shown as **X2**.
   - Edit the radius to **.6** and press **ENTER**.

5. From the dashboard, select the **Sets** tab:
   - Click **Set 1** and then **Set 2** to see the two round sets you have defined within the one round feature.

6. Click **Complete Feature ✓**.

7. With **Round 1** still selected, right-click and select **Pattern** from the pop-up menu:
   - Click **Complete Feature ✓**.

   **If Pattern** is not available in the pop-up menu, you may not have added the rounds to **Extrude 5[1]**, the first instance of the pattern.

8. Check and then save your work:
   - Spin the model to view your design.
   - Press **CTRL + D**.
   - Click **Save ✓**.

---

© 2009 PTC
9. If necessary, in the model tree, expand **Pattern 1 of Extrude 5**:
   • Click **Extrude 5[1]** to identify the first instance of the pattern.
     This is where you will place the round feature.

10. From the **Engineering** group, click **Round**:
    • Select the edge shown.
    • Edit the radius to **.3** and press ENTER.
    • Click **Complete Feature ✓**.

11. With **Round 2** still selected, right-click and select **Pattern** from the pop-up menu:
    • Click **Complete Feature ✓**.

**Step 6:** Use round and chamfer features to add final details to your design.

1. If necessary, press **CTRL + D**.

2. Click **Round**:
   • Press and hold **CTRL** while you select the two edges shown.
   • If necessary, edit the radius to **.3** and press ENTER.
   • Click **Complete Feature ✓**.
3. Click **Round**:
   - Zoom in as required and select the edge shown.
   - If necessary, edit the radius to 0.3 and press ENTER.
   - Click **Complete Feature**.

4. Spin the model until you can view the back of the wheel.

5. From the **Engineering** group, click **Edge Chamfer** from the Chamfer types drop-down menu:
   - Select the inner edge of the hole as shown.
   - If necessary, edit the chamfer D value to 0.3 and press ENTER.
   - Click **Complete Feature**.

**Step 7:** View your design using the Shading With Reflections display style.

1. From the In Graphics toolbar, select **Shading With Reflections** from the Display Style types drop-down menu.

2. Check and then save your work:
   - Spin the model to view your design.
   - Press **CTRL + D**.
   - Click **Save**.
3. Click **Open** and double-click the ASTON_MARTINASM:
   - Spin the car and check your design.

4. Select **Shading With Edges** from the Display Styles drop-down.

   ![Car Image]

   Now that you have added more detail, your wheel looks a lot better on the Aston Martin!

**Step 8:** Create a cross section to verify the fit between the wheel and tire.

1. In the graphics area, click to select any of the four WHEEL.PRT models:
   - Right-click and select **Select Parent** from the pop-up menu.
     - This will select the parent assembly WHEEL.ASM.
   - With WHEEL.ASM selected, right-click and select **Open**.

2. From the **Model Display** group, select **Z Direction** from the **Section** types drop-down menu:
   - Drag the shaded red arrow to adjust the section offset.
3. From the dashboard:
   • Click **Z** and select **Y** from the section drop-down menu.
   • Click **3D Dragger** to enable free positioning of the offset plane.
   • Drag the shaded arrows and rings to adjust the section offset.

4. From the dashboard:
   • Click **Y** and select **X** from section drop-down menu.
   • Click the **Properties** tab and edit the section name to be **A**.
   
   ![Image showing interference between wheel and tire highlighted]

   **With the Section dashboard open, interference between the wheel and tire is highlighted.**

5. From the dashboard, click **2D View** and in the 2D Section Viewer dialog box:
   • Use the In Graphics toolbar to adjust the orientation and display of the 2D section.

6. Click **Complete Feature ✓**.
7. From the In Graphics toolbar, click **Named Views** and select **Right** from the drop-down menu.

It appears that you have a few design issues. You have already seen the interference between the wheel and tire, but it also appears that the outer cylinder of the wheel is not wide enough to fit the tire. Let's go investigate and fix the issues.

8. From the ribbon, select the **Analysis** tab.

9. From the **Measure** group,
   - select **Summary** from the Measure types drop-down menu:
     - Select the inner edge of the tire as shown.

This measurement shows that the depth of the outer wheel cylinder should be edited to 7.

10. From the Measure dialog box,
    - click **Diameter**:
      - Cursor over the cylindrical surface of the tire and when it highlights, select it.

This measurement shows that to fit the tire, the minor diameter of the wheel should be reduced to 15.15.

11. From the Analysis tab, click **Summary** to close the Measure dialog box.
Step 9: Edit the wheel to fit the tire.

1. Press **CTRL + D**.
2. In the model tree, expand the WHEEL.PRT node.
3. Right-click **Extrude 1** and select **Edit** from the pop-up menu:
   - Move your cursor over the 4.5 dimension value, when it highlights, double-click it.
   - Type a new value of 7 and press ENTER
4. From the Quick Access toolbar, click **Regenerate**.

5. In the model tree with the WHEEL.PRT node still expanded:
   - Right-click **Extrude 2** and select **Edit**.
   - Double-click the 15.6 dimension value.
   - Type a new value of **15.15** and press ENTER.
6. From the Quick Access toolbar, click **Regenerate**.

You have received info from the marketing team, they think the wheel needs more spokes. Also, the engineering team thinks the wheel is be too heavy.

7. Scroll to the bottom of the model tree, right-click section A and select **Deactivate** from the pop-up menu.

To redefine a cross section, select **Edit Definition** from the pop-up menu.
8. In the model tree with the WHEEL.PRT node still expanded:
   - Right-click **Pattern 1 of Extrude 5** and select **Edit**.
   - Double-click the pattern value 6, shown as **6 EXTRUDES**.
   - Type a new value of **9** and press ENTER.

9. Click **Regenerate** to update the pattern.

**Step 10:** Edit the length of the wheel hub from the drawing.

1. From the Quick Access toolbar, click **Windows** and select **ASTON_MARTIN.ASM** to activate the window.
2. Click **Named Views** and select **Front** from the drop-down menu.

Our engineers are worried that the wheel base of the car is a little too narrow, let's go fix that.

3. Click **Open** and double-click **WHEEL.DRW**.
Because Creo Parametric is bi-directionally associative, all edits made in WHEEL.PRT are automatically updated in the drawing. Just as you have seen edits automatically updated in the ASTON_MARTIN.ASM.

4. In the SECTION A-A view, locate the dimension value 1 used to offset the sketch plane of Extrude 4.

5. Press ALT and select the dimension 1:
   - Right-click and select Modify Nominal Value from the pop-up menu.
   - Edit the value to 4 and press ENTER.

6. Click Regenerate from the Quick Access toolbar.

7. From the Quick Access toolbar, click Windows and select ASTON_MARTIN.ASM.

8. Click Regenerate from the Quick Access toolbar.
9. Admire your car and then save your work:
   • Spin the car to view the design.
   • Press CTRL + D.
   • Click Save.

10. Click Close Window until you have closed all of the open windows.
   • From the Home tab, Data group, click Erase Not Displayed:
     – In the Erase Not Displayed dialog box, click OK.

Congratulations! You have completed your design of the Aston Martin wheel. In the next module, you will create a photorealistic image of the car using render capabilities within Creo Parametric.

This completes the procedure.
Module 6

Photorealistic Rendering

Module Overview
Photorealistic images are a great way to let others see and evaluate the esthetics of your design. Images rendered from models in Creo Parametric can also be used in catalogs or marketing materials.

In this module, you will learn to assign material specific appearances to a model, place that mode in a room and defined scene. Finally you will learn to render and output the photorealistic image you create.

Objectives
After completing this module, you will be able to:
• Assign an appearance or color to a model.
• Define the scene and room that a model will be rendered in.
• Render a photorealistic image of a model.
• Output a rendered image to a graphics file.
Photorealistic Rendering

There are four basic steps to creating a photorealistic image in Creo Parametric:

1 - Assign Appearances

2 - Define the Scene

3 - Render Setup

4 - Render the Scene

The Render Tab

In the Render tab, you can assign appearances to your model, set your model in a scene, apply perspective and create photorealistic renderings of your design models.

Assign Appearances

The Appearance Gallery dialog box allows you to view, search, and assign available appearances to a model. You can assign or set appearances to an entire part, individual surfaces or quilts. In the assembly mode, you can assign an appearance to the entire assembly, active individual components or parts in the assembly.
Define the Scene

A scene file is a collection of render settings applied to a model. These settings include lights, rooms, and environment effects.

You can save only one scene with the model. When you reload the model from its location, the scene that is saved with the model is activated.

Room and lights within the scenes scale parametrically, depending on the size of the model to which the scene is applied. The room is automatically re-sized or the position of the lights change making the scene reusable with any kind of geometry.

Render Setup

Various rendering parameters can be defined in the Render Setup dialog box.

The quality of the render can be set in the Render Setup dialog box. The default option is Draft but the quality should be set to High or Maximum for quality outputs.

💡 As you increase the quality of the render, you also increase the time required to complete the render. Setting the quality level to Maximum will create an even higher quality image, however, it may take too long to complete on some lower-end computers.

By default, Creo Parametric will render to the Full Window of the graphics area. Other output types such as Tiff, RGB, JPEG, and so on can be set as the render output.

You can set and save the output type of a rendered model from the Render Setup dialog box.

Render the Scene

After appearances have been applied, the scene defined, and the output type set, you can render a model by clicking Render Window from the Render tab.
PROcedures - Photorealistic Rendering

Scenario

Now that the design of your wheel is complete, it’s time to create photorealistic images you can send to the marketing group!

In this exercise you will assign material specific appearances to both the wheel and tire. You will then create a photorealistic rendering of the wheel assembly. Finally, you will create a photorealistic rendering of the top level Aston Martin slot car assembly.

**Step 1:** Set your working directory and open WHEEL.ASM.

1. If necessary, start Creo Parametric 2.0.

2. From the Home tab, Data group, click *Select Working Directory*.

3. In the Select Working Directory dialog box:
   - Navigate to the folder *Creo2_Adv_Primer*.
   - Double-click the folder *Module_02-06*.
   - Double-click the folder *Render*.
   - Click OK to set the folder as your working directory.

4. From the Quick Access toolbar, click *Open*:
   - Select WHEEL.ASM and click *Open*.

5. If necessary, from the In Graphics toolbar, click *Datum Display Filters* and disable the display of all datum features.

6. From the In Graphics toolbar, select *Shading With Reflections* from the Display Style types drop-down menu.
Step 2: Apply a chrome appearance to WHEEL.PRT.

The wheel model was created using the default Creo Parametric gray color. It will look much better in the final rendering if you apply a chrome appearance from the appearance gallery.

1. Select Shading With Edges from the Display Style types drop-down menu.
2. In the model tree, right-click WHEEL.PRT and select Open from the pop-up menu.

3. From the ribbon, select the View tab.
4. In the Model Display group, directly below the Appearance Gallery color ball, click the Appearance Gallery drop-down menu.

5. In the Library section of the Appearance dialog box:
   - Click std-metals.dmt.
   - Ensure the Photolux Library folder is open.
   - Expand the Metals folder node.
   - Scroll as required and select adv-metal-chrome.dmt.

6. From the Library section of the Appearance dialog box, select adv-chrom-plate:
   - At the top of the model tree, select the name WHEEL.PRT with the Paintbrush cursor.

As soon as you select an appearance, the Appearance Gallery will close, the color ball’s display will change and the cursor will become a Paintbrush.
7. Middle-click or click **OK** from the Select dialog to apply the appearance.

> The true chrome shine will be displayed when the model is rendered.

**Step 3:** Apply a matted black rubber appearance to TIRE.PRT.

> The tire looks a little light and shiny. Apply a matted black rubber appearance from the appearance gallery.

1. From the Quick Access toolbar, click **Close Window**.
2. In the model tree, right-click TIRE.PRT and select **Open** from the pop-up menu.
3. From the ribbon, select the **View** tab.
4. In the **Model Display** group, directly below the **Appearance Gallery** color ball, click the **Appearance Gallery** drop-down menu.

5. In the **Library** section of the Appearance dialog box:
   - Click **adv-metal-chrome.dmt**.
   - Ensure the **Photolux Library** folder is open.
   - Expand the **Misc** folder node.
   - Scroll as required and select **adv-rubber.dmt**.

6. From the **Library** section of the Appearance dialog box, select **adv-rubber-matte-black**:
   - At the top of the model tree, select the name **TIRE.PRT** with the **Paintbrush** cursor.
7. Middle-click or click **OK** from the Select dialog to apply the appearance.

8. From the Quick Access toolbar, click **Close Window** 📋.

---

**Step 4:** Set the wheel assembly into a scene and room.

---

**Before rendering, you have to put your model in a “scene”.** The lighting, reflections, walls and floors that are part of the scene help make your rendered model look real.

---

1. From the **Render** tab, **Scene** group, click **Scene** 🌍.
2. In the Scene Gallery section of the **Scene** tab:
   - Select the scene named **Photolux-Studio-Soft**.
   - Right-click **Photolux-Studio-Soft** and select **Activate** from the pop-up menu.
3. With the Scenes dialog box still open, select the **Room** tab:

- In the Size section of the tab, click **Align Floor**.

  ![Align Floor](image)

  The floor is now snapped to the bottom of the tire.

4. Zoom out until you can see the round floor:

- Press and hold CTRL, then middle-click and drag upward to zoom out.

5. Use spin, pan, and zoom tools to orient your model to an orientation you want to render:

- Middle-click and drag to spin.
- Press and hold SHIFT, then middle-click and drag to pan.
- Press and hold CTRL, then middle-click and drag to zoom.

6. From the Scenes dialog box, click **Close**.

---

**Step 5:** Render the wheel assembly.

Render your model using the faster **Draft** quality settings. After you have the orientation, scene and appearances the way you want them, then increase the quality.

1. From the **Render** group, click **Render Window**:

   ![Render Window](image)

   - If necessary, adjust the orientation, scene, appearances and lighting and re-render the model until it looks the way you want it to.
2. Click **Render Setup** and in the Render Setup dialog box:
   - Click **Draft** and select **High** from the Quality drop-down list.
   - Click **Close**.

3. Click **Render Window**.

As you increase the quality of the render, you also increase the time required to complete the render. Setting the quality level to **Maximum** will create an even higher quality image, however, it may take too long to complete on some lower-end computers.

4. Click **Save**.

5. Click **Close Window** until you have closed all of the open windows.

**Step 6:** Set the Aston Martin assembly into a scene and render it.

1. Click **Open** and double-click **ASTON_MARTIN.ASM**.

2. From the In Graphics toolbar, select **Shading** from the Display Style types drop-down menu.

3. In the model tree, right-click on **SLOT_GUIDE.ASM** and select **Set Representation to > Exclude**.

Temporarily excluding the **SLOT_GUIDE.ASM** will allow the floor of the room to automatically be aligned to the bottom of the tires when you setup the room.
4. From the Render tab, Scene group, click Scene.

5. In the Scene Gallery section of the Scene tab:
   • Select the scene named Photolux-Studio-Soft.
   • Right-click Photolux-Studio-Soft and select Activate from the pop-up menu.

6. With the Scenes dialog box still open, select the Room tab:
   • In the Size section of the tab, click Align Floor.

   The floor is now snapped to the bottom of the tires.

7. Zoom out until you can see the round floor of the room.
8. Use spin, pan, and zoom tools to orient your model to an orientation you want to render:
   • Middle-click and drag to spin.
   • Press and hold SHIFT, then middle-click and drag to pan.
   • Press and hold CTRL, then middle-click and drag to zoom.

9. From the Scenes dialog box, click Close.
The last time you rendered the wheel assembly, the output quality was set to **High**. Unless you have restarted Creo since that time, the quality is still set at **High**. If your computer had a hard time rendering the wheel assembly at the higher quality, you may want to set the quality back to **Draft** before you render the car.

10. Click **Render Window**.

Step 7: Save the rendered image and then save and close the models.

1. Click **File > Save As > Save a Copy** and in the Save a Copy dialog box:
   - Browse to the folder **Module_02-06**.
   - Click **JPEG (*.jpg)** from the Type drop-down list.
   - Click **OK** to save the JPEG file.

© 2009 PTC Module 6 | Page 11
2. Save the assembly and then erase the files from session:
   - Click **Save**.
   - Click **Close Window** until you have closed all of the open windows.
   - Click **Erase Not Displayed**:
     - In the Erase Not Displayed dialog box, click **OK**.

Congratulations! You have completed the rendering exercise for the Aston Martin slot car.

This completes the procedure.
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This product also includes software written by Tim Hudson (tjh@cryptsoft.com). pcre-4.3.2-src.zip - Perl Compatible Regular Expression Library version 4.3. http://www.pcre.org; Provided pursuant to: PCRE License. lpng120.zip - PNG image library version 1.2.0. http://www.libpng.org; Provided pursuant to: http://www.libpng.org/pub/png/src/libpng-LICENSE.txt. libpng, Copyright © 2004 Glenn Randers-Pehrson, which is distributed according to the disclaimer and license (as well as the list of Contributing Authors) at http://www.libpng.org/pub/png/src/libpng-LICENSE.txt. METIS is © 1997 Regents of the University of Minnesota.

Curl software, Copyright ©1996 - 2005, Daniel Stenberg, All rights reserved. Software is used under the following permissions: Permission to use, copy, modify, and distribute this software for any purpose with or without fee is hereby granted, provided that the above copyright notice and this permission notice appear in all copies. THE SOFTWARE IS PROVIDED AS IS, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use, or other dealings. Java Advanced Imaging (JAI) is licensed pursuant to the Sun Java Distribution License (JDL) (see java.net). The terms of the JDL shall supersede any other licensing terms for PTC software with respect to JAI components. Regular expression support is provided by the PCRE library package, which is open source software, written by Philip Hazel, and copyright by the University of Cambridge, England. This software is based in part on the work of the Independent JPEG Group. Regular Expressions support was derived from copyrighted software written by Henry Spencer, Copyright © 1986 by University of Toronto. SGML parser: Copyright © 1994, 1995, 1996, 1997, 1998 James Clark, 1999 Matthias Clasen. XML parser and XSLT processing was developed using Libxml and Libxslt by Daniel Veillard, Copyright © 2001. libWWW (W3C’s implementation of HTTP) can be found at: http://www.w3.org/Libwww; Copyright © 1994-2000 World Wide Web Consortium, (Massachusetts Institute of Technology, Institut National de Recherche en Informatique et en Automatique, Keio University). All Rights Reserved. This program is distributed under the W3C's Software Intellectual Property License at: http://www.w3.org/Consortium/Legal/2002/copyright-software-20021231. This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See W3C License http://www.w3.org/Consortium/Legal for more details. Copyright © 1995 CERN. "This product includes computer software created and made available by CERN. This acknowledgment shall be mentioned in full in any product which includes the CERN computer software included herein or parts thereof." Perl support was developed with the aid of Perl Kit, Version 5.0. Copyright © 1989-2002, Larry Wall. All rights reserved. The cad2eda program utilizes wxWidgets (formerly wxWindows) libraries for its cross-platform UI API, which is licensed under the wxWindows Library License at http://www.wxwindows.org. ZLib - Compression library; Copyright 1995-2005 Jean-loup Gailly and Mark Adler; Provided pursuant to ZLib License at http://www.zlib.net/zlib_license.html. ATLPort copyright 1999, 2000 Boris Fomitchev is provided by the copyright holder "as is" with absolutely no warranty expressed or implied. Permission to use or copy this software for any purpose is granted without fee, provided the foregoing notices are retained on all copies. Permission to modify the code and to distribute modified code is granted, provided the above notices are retained and a notice that the code was modified is included with the above copyright notice. PTC reserves the right to modify this code and may do so without further notice. OpenCASCADE software is subject to the Open CASCADE Technology Public License Version 6.2 (the "License"). This software may only be used in compliance with the License. A copy of the License may be obtained at http://www.opencascade.org. The Initial Developer of the Original Code is Open CASCADE S.A.S., with main offices at 15 bis, rue Ernest Renan 92136, Issy Les Moulineaux, France. The Original Code is copyright © Open CASCADE S.A.S., 2001. All rights reserved. "The Original Code" and all software distributed under the License are distributed by OpenCASCADE on an "AS IS" basis, without warranty of any kind, and the Initial Developer hereby disclaims all such warranties, including without limitation, any warranties of merchantability, fitness for a particular purpose, or noninfringement (please see the License for the specific terms and conditions governing rights and limitations under the License). PTC product warranties are provided solely by PTC. Certain Pro/TOOLMAKER functions/libraries are as follows: CSubclassWnd version 2.0 - Misc. C++ software; Copyright © 2000 NEWare Software. STLPort - C++ template library: Copyright © 1999-2000 Boris Fomitchev; Provided pursuant to: STLPort License http://stlport.sourceforge.net/License.shtml. Zip32 - Compression library; Copyright © 1999-2007 Igor Pavlov; Provided pursuant to 7-Zip License http://www.7-zip.org/license.html. The implementation of the loop macro in CoCreate Modeling is based on code originating from MIT